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Business Reports

FTD Mercury allows you to generate several different reports to assist you in the daily operations of 
your shop. In addition to financial reporting functionality, the reports in this section are designed as 
business management tools. Each report is generated using a Microsoft Excel template.

This section is designed to educate you on all of the reports that are available to generate from the 
program and how to customize each report for the unique needs of your store. This section helps 
you understand the purpose of each report, how to access and print each report, and contains an 
example of each report.

Using Business Report Templates
IMPORTANT This section discusses templates for business reports. For information on Marketing templates (standard 

templates and templates used with the Mercury Marketing module), see Mercury Marketing on page 
15–1.

FTD Mercury includes several Microsoft Excel and Microsoft Word templates that help you generate 
reports, letters, and mailing labels. Templates eliminate the need for setting up the format of these 
documents; they contain all the formatting and text that you need to generate these documents. 
All you need to do is click on the template, specify what type of information you want to include, 
and your letters, reports, and labels are generated for you automatically. The system retrieves 
information from your store’s database to generate each type of report. Once the report is 
displayed on your screen, you can save or print it.

IMPORTANT In order to use Business Reports, you must have full access to Reports in Mercury Administration. You can 
control employee access to Business Reports based on employee types. For more information, see 
Window Access Screen on page 24–57. 

You may use the following methods to access your FTD Mercury templates.

From Within FTD Mercury
TASK To access FTD Mercury templates from the FTD Mercury Main Menu:

1 Click Business Reports.
2 Double-click Mercury Forms.
3 Double-click the name of the report you want to generate.
4 If you receive a security warning about the template containing macros, click Enable Macros. 

This is normal and the macros are required to generate the report or letter.
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From Within Microsoft Word or Microsoft Excel
TASK To access FTD Mercury templates from within Microsoft Word or Microsoft Excel:

1 Either open Microsoft Word (for letters) or Microsoft Excel (for reports).
2 On the File menu, click New.
3 In the New Document pane (Word) or the New Workbook pane (Excel) on the right side of the 

screen, click On my computer.
4 In the Templates window, click the Mercury Forms tab.
5 Double-click the template you want to open.
6 If you receive a security warning about the template containing macros, click Enable Macros. 

This is normal and the macros are required to generate the report or letter.
7 Depending on the report or letter, you may have to configure one or more windows to set 

necessary options for the report or letter (such as a date range).
8 Click Finish to generate the report or letter.

List of Business Reports
FTD Mercury provides the following business reports:

» Abbreviated Customer Master List with Balance Report

» Abbreviated Customer Master List with Days Late Report

» Aged Analysis Reports

» Business Snapshot Report

» Credit Card Settlement History Report

» Customer Account Payment Report

» Customer Master List

» Employee Analysis Report

» Employee Sales Report

» Message Report

» Payment Type Totals Report

» Product Comparison Report

» Product Sales Reports—There are several variations on this report:

» List of Product Codes Summary Report

» List of Product Codes Detail Report

» Sales by Product Code Summary Report

» Sales by Product Code Detail Report

» Product Sales Report by Date by Occasion by Product Summary Report

» Product Sales Report by Date by Occasion by Product Detail Report

» Reciprocity Report

» Report of Orders Filled

» Sales by Referral Code Report

» Sales Summary Report

» Sales Tax Report
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» Standing Order Log Detail Report

» Standing Order Log Summary Report

» Tax Exempt Customer Report

» Ticket Report

» Wire Reconciliation Report

» Wire Service Incoming/Outgoing Report

Abbreviated Customer Master List with Balance 
Report

The Abbreviated Customer Master List with Balance report provides you with a list of all your 
customers as well as their current balance totals. You can select particular payment types to include 
in the report, or all payment types. This report is particularly useful for stores with many customers 
that wish to have abbreviated customer information on hand. For a longer customer report with 
more detailed information, see the Customer Master List on page 19–22.

Figure 19-1: Abbreviated Customer Master List with Balance Report

Generating the Abbreviated Customer Master List with Balance 
Report
TASK To generate the Abbreviated Customer Master List with Balance report:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click Mercury Forms.
3 Double-click on the Abbreviated Customer Master with Balance icon to open the template.
4 If a window opens asking whether you wish to enable or disable macros, click Enable Macros.
5 If you receive the message “This application is about to initialize ActiveX controls...” click OK.
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6 In the Store of Origin field, click the arrow and select the store’s data that you want to use for 
the report.

7 In the Please select payment type section, click in the check boxes so check marks appear for 
any combination of payment types you wish to include in this report.

8 If you want to print customers with particular marketing types, click Marketing Criteria 
Selection so that a check mark appears (otherwise leave this option unchecked). This allows 
you to filter customer information so that, for example, you can print only Business accounts in 
the report. (If this area is blank, it means that you have no marketing categories set up. See 
Marketing Screen on page 24–21 for information on setting up these categories.)
To select marketing categories to print, first click on a category so that a drop-down arrow 
displays. Click this arrow to display a drop-down list of marketing types. Then check which 
types you want to print.
To print only customers with no marketing information specified in the Customer Detail 
Information window, first check the Marketing Criteria Selection option so that a check mark 
appears, then check Customers with No Marketing Criteria.

9 In the Sort Option section, choose whether you wish to list customers according to Default Pay 
Method, Last Purchase Date, or Name. If you select to sort by last purchase date, specify the 
last purchase date by clicking the down arrow in the date field and selecting the date from the 
calendar.

10 If you want to only display open item customers with available credit not allocated to unpaid 
tickets, select the check box so that a check mark appears.

11 Click Finish. The report generates and opens in Excel.
12 To print your report from Excel, on the File menu, click Print.
13 If you want to save the report from Excel, on the File menu, click Save.

Abbreviated Customer Master List Window
The Abbreviated Customer Master List window enables you to configure settings for the 
Abbreviated Customer Master List with Balance and the Abbreviated Customer Master List with 
Days Late reports.
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Figure 19-2: Abbreviated Customer Master List Window

The Abbreviated Customer Master List window contains the following settings.

Abbreviated Customer Master List with Days 
Late Report

The Abbreviated Customer Master List with Days Late report provides you with a list of all your 
customers as well as the number of days their payments are late. It is particularly useful if you have 

Table 19-1: Abbreviated Customer Master List Window Settings

Setting Description

Store of Origin From this list, select the store with which the customer is associated. If you have 
multiple stores, you can select All Stores.

Payment Types Select the payment type(s) you want to include in the report. You can select 
Cash, Check, Credit, Debit, House, or Gift Certificate.

Marketing Criteria 
Selection

If you select this option, you can filter the report so it includes customers with 
specific marketing criteria or no marketing criteria. If you select Customers with 
Marketing Criteria, you can select the marketing categories to include.

Sort Option You can select to sort the report by the Default Pay Method, the Last Purchase 
Date (requires you specify the date), or by Name.

Open Item Customers 
with Credit

This option is only available for the Abbreviated Customer Master List with 
Balance Report. You can check this box to display open item customers with 
available credit not allocated to unpaid tickets.
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many customers and you wish to have abbreviated customer information on hand. For a longer 
customer report with more detailed information, see the Customer Master List on page 19–22.

Figure 19-3: Abbreviated Customer Master List with Days Late Report

Generating the Abbreviated Customer Master List with Days Late
TASK To generate the Abbreviated Customer Master List with Days Late:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click Mercury Forms.
3 Double-click on the Abbreviated Customer Master with Days Late icon to open the template.
4 If a window opens asking whether you wish to enable or disable macros, click Enable Macros.
5 If you receive the message “This application is about to initialize ActiveX controls...” click OK.
6 In the Store of Origin field, click the arrow and select the store’s data that you want to use for 

the report.
7 In the Please select payment type section, click in the check boxes so check marks appear for 

any combination of payment types you wish to include in this report.
8 If you want to print customers with particular marketing types, click Marketing Criteria 

Selection so that a check mark appears (otherwise leave this option unchecked). This allows 
you to filter customer information so that, for example, you can print only Business accounts in 
the report. (If this area is blank, it means that you have no marketing categories set up. See 
Marketing Screen on page 24–21 for information on setting up these categories.)
To select marketing categories to print, first click on a category so that a drop-down arrow 
displays. Click this arrow to display a drop-down list of marketing types. Then check which 
types you want to print.
To print only customers with no marketing information specified in the Customer Detail 
Information window, first check the Marketing Criteria Selection option so that a check mark 
appears, then check Customers with No Marketing Criteria.

9 In the Sort Option section, choose whether you wish to list customers according to Default Pay 
Method, Last Purchase Date, or Name. If you select to sort by last purchase date, specify the 
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last purchase date by clicking the down arrow in the date field and selecting the date from the 
calendar.

10 Click Finish. The report generates and opens in Excel.
11 To print your report from Excel, on the File menu, click Print.
12 If you want to save the report from Excel, on the File menu, click Save.

Aged Analysis Reports
The Aged Analysis reports provide you with an analysis of your house account balances. The report 
includes only those accounts with balances for the selected store(s) and reporting period. 

Aged Analysis reports contain account balances and aging on accounts from the sale date relative 
to the date you generate the report. Aging is calculated nightly. You can use Aged Analysis reports 
to view potential future cash flow, see how much customers owe, and decide what steps you need 
to take to recoup money that you are owed. To assist your collection efforts, Aged Analysis detail 
and summary reports include customers’ phone numbers. You will typically generate Aged Analysis 
reports monthly, either just before or just after you create statements. By printing each month’s 
Aged Analysis report, you can review account aging for a previous month or look up a customer’s 
balance when access to a terminal is not possible.

NOTE To view aging as of a statement date, use Statement Search. In the Search menu, click Statement Search. 
Highlight the statement run and click Print. The Statement List report that displays contains the aging for 
the account as of the selected statement run.

You can generate Aged Analysis reports for balance forward or open item accounts at individual 
stores or at all stores. You may sort detail and summary reports according to customer ID, sale date, 
or sort name. By default, the Aged Analysis reports set the Balance Forward date one month prior 
to the current date. By setting the Account Balance date later than the Balance Forward date, you 
can include future transactions in the Aged Analysis report. 

The three types of aged analysis reports are:

» Detail Report - lists each customer that has an open balance, as well as each individual 
transaction for the customer that occurred after the balance forward date. The report also 
prints the ticket number, product code(s) for each transaction, purchase date, and customer 
balance. Grand totals (for current, 30, 60, 90, 120+ days, and future, if selected) for each store 
are printed at the bottom of the report.

» Summary Report - lists each customer name and phone number, and the current, 30, 60, 90, 
120+, and future balances (if selected) for each customer. Individual transactions are not listed.

» Grand Total Report - does not list individual customers. Total amounts for all customers are 
listed, separated by current, 30, 60, 90, 120+, and future balances.
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Figure 19-4: Aged Analysis Report - Detail

The detailed Aged Analysis report contains the following information.

Table 19-2: Aged Analysis Detail Report Columns

Column Description

Customer No. The account number of the customer with aged balance(s).

Customer Name Name of the customer with aged balance(s).

Phone Number Phone number of the customer with aged balance(s).

Days Late Aging bucket or days late of the customer’s oldest transaction. If the oldest 
transaction is less than 120 days old, Days Late will show the aging bucket of 
the transaction (30 = transactions 30-60 days old; 60 = transactions 61-90 
days old; or 90 = transactions 91-120 days old). For transactions 121 days and 
older, Days Late shows the actual days late.

Last Payment Date Date on which the last payment was entered for the customer account.

Accounting Type Indicates whether the customer’s account is set up as a balance forward or 
open item account.

Ticket # Number associated with an order.

Sale Date Date of the ticket.

Del Date Scheduled delivery date.

Transaction Type Type of transaction. Transactions with balances prior to the Balance Forward 
date appear with transaction type of Balance Forward. If you generate the 
Aged Analysis report after running statements you may see Transaction Type 
of Finance Charge.

Product Code Code for the product.

Product Description Product name.

Tax Code Tax code associated with the transaction.

Total Amount Total amount for the transaction.
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Figure 19-5: Aged Analysis Report - Summary

Figure 19-6: Aged Analysis Report - Grand Total

Generating Aged Analysis Reports
TASK To generate Aged Analysis reports:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click Mercury Forms.
3 Double-click on the Aged Analysis Report icon to open the template.
4 If a window opens asking whether you wish to enable or disable macros, click Enable Macros.
5 In the Store of Origin field, click the arrow and select the store’s data that you want to use for 

the report. 
6 In the Customer Type section, select which customers’ information that you want to view, 

Balance Forward, Open Item, or both.
7 In the Report Type section, select the type of report that you want to print. See the information 

at the beginning of this section for the descriptions of the report types.
8 In the Past Due section, select the past due accounts that you want to view. You can choose 

accounts that are current (up-to-date) or accounts that are 30, 60, 90, and/or 120+ past due.
9 In the Print Order section, select how you want to sort the printing order of the data records. 

You can sort the records by Customer ID, Sale Date, or Sort Name (customer name).
10 In the Balance Forward Date field, click the arrow and select the balance forward date of the 

customers that you want to print.
11 In the Account Balance as of field, click the arrow and select the date for calculating aging. 

Setting the Account Balance as of date later than the current date allows you to include future 
transactions in the Aged Analysis report.

12 Select Include Wire Service Accounts only if you want to include wire service accounts (FTD, 
TEL, etc.) in the report.

13 Click Finish. The report generates and opens in Excel.

Acct Balance Running total of the transaction total amounts for the customer.

Table 19-2: Aged Analysis Detail Report Columns (cont.)

Column Description
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14 To print your report from Excel, on the File menu, click Print.
15 If you want to save the report from Excel, on the File menu, click Save.

Aged Analysis Report Window
The Aged Analysis Report window allows you to configure settings for the Aged Analysis report. 
When you have finished configuring the settings, click Finish to generate the report and open it in 
Microsoft Excel.

Figure 19-7: Aged Analysis Report Window

The Aged Analysis Report window contains the following settings.

Table 19-3: Aged Analysis Report Window Settings

Setting Description

Store of Origin Select the store with which this customer is associated. If you are set up as a 
multi-store shop, you can also select All Stores.

Customer Type Select whether you want to include customers with Balance Forward accounts, 
customers with Open Item accounts, or both.

Report Type Select whether you want to generate a Detail Report, a Summary Report, or a 
Grand Total Report.

Past Due Select criteria for including customers. You can select any combination of 
customers who are current, 30 days past due, 60 days past due, 90 days past due, 
and/or 120+ days past due.
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Business Snapshot Report
The Business Snapshot report is a tool that gives you an immediate analysis of what is going on in 
your business for a given day or date range. You can generate Business Snapshot reports for 
individual stores or for all stores. Business Snapshot reports give you a quick look at the activity in 
your business for the reporting period. For example, you could generate the Business Snapshot 
report in the morning to see how heavy your delivery schedule for the day will be. You can also get 
an idea of your staffing needs throughout a day by tracking various types of sales by hour. Since 
Business Snapshot reports include cancelled, pending, and incomplete sales, the information in 
Business Snapshot should not be used to balance completed sales. For balancing purposes, refer to 
the Sales Summary Report on page 19–50.

Business Snapshot includes four reports--Sales Analysis, Delivery Analysis, Product Analysis, and 
Wire Analysis--in a single Excel file. 

» Sales Analysis - summarizes number and dollar value of sales for the reporting period by type 
of order, payment method, and time of day for sales entered in Order Entry and Point of Sale. 
You can use this report to see what your sales are.

» Delivery Analysis - summarizes the number and dollar value of deliveries scheduled for the 
reporting period by their workflow status. You can use this report as an overview of your 
delivery schedules and delivery staffing needs.

» Product Analysis - summarizes the number and dollar value by product categories and 
individual products for deliveries scheduled for the reporting period. You can use this report as 
an overview of how the sales in the reporting period will affect your inventory. 

» Wire Analysis - summarizes the number and dollar values for each wire service of incoming 
and outgoing wire sales attached in Order Entry and Point of Sale. 

To navigate between reports, click tabs at the bottom of the screen. To print all four reports at once, 
you must select Entire workbook in the Excel print dialog box.

Sales Analysis
The Sales tab displays by default. This tab displays the Sales Analysis report. 

Print Order Select the print order for the report. You can select Customer ID, Sale Date, or 
Sort Name.

Balance Forward Date If you are including customers with balance forward accounts, select the date for 
the balance forward accounts you want to include.

Account Balance as of Date equal to or later than the date on which you are running the report. Setting 
this date later than the date of the report allows you to include future 
transactions in the report.

Include Wire Service 
Accounts

Select this box if you want to include wire service accounts (FTD, TEL, etc.) in this 
report.

Table 19-3: Aged Analysis Report Window Settings (cont.)

Setting Description
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Figure 19-8: Business Snapshot – Sales Analysis Report

The Sales Analysis report contains the following information.

Table 19-4: Sales Analysis Report Field Descriptions

Column Description

Store Name Name of store selected in the Business Snapshot window. If you are set up 
with multiple stores, All Stores indicates that the report contains data for all 
stores. 

Sales Entered Reporting period selected in the Business Snapshot window. The Sales 
Analysis report shows sales for this period.

Order Entry/Manual Count and total value for sales for the reporting period that were entered or 
attached in Order Entry.

POS Count and total value for sales for the reporting period that were entered or 
attached in Point of Sale.

Total Total of count and total value for sales for the reporting period that were 
entered or attached in Order Entry and Point of Sale.

Average Average value of the total for the type of order, payment method, or hourly 
sale.

Order Summary Count and value for sales for the reporting period for Order Entry, Point of 
Sale, and Total sales summarized by the type of order.

NOTE: Wire order sales include all fees and taxes.

Sales Pay Method Count and value for sales for the reporting period for Order Entry, Point of 
Sale, and Total sales summarized by payment method.

Sales By Hour Count and value for sales for the reporting period for Order Entry, Point of 
Sale, and Total sales summarized by the hour during which the sale took 
place.

Count Total Count Total Count Total Average
Order Summary
DELIVERY ORDERS 3 $218.44 1 $83.95 4 $302.39 $75.60
CARRY OUT ORDERS 0 $0.00 1 $12.50 1 $12.50 $12.50
PICKUP ORDERS 0 $0.00 0 $0.00 0 $0.00 $0.00
INCOMING WIRE ORDERS 10 $555.95 1 $43.00 11 $598.95 $54.45
OUTGOING WIRE ORDERS 0 $0.00 0 $0.00 0 $0.00 $0.00

STORE TOTAL 13 $774.39 3 $139.45 16 $913.84 $57.12

Sales Pay Method
CASH SALES 0 $0.00 0 $0.00 0 $0.00 $0.00
HOUSE CHARGE SALES 3 $193.43 0 $0.00 3 $193.43 $64.48
MANUAL TICKET SALES 0 $0.00 0 $0.00 0 $0.00 $0.00
DEBIT MEMOS 0 $0.00 0 $0.00 0 $0.00 $0.00
CREDIT MEMOS 0 $0.00 0 $0.00 0 $0.00 $0.00
CREDIT CARD SALES 1 $75.00 2 $96.45 3 $171.45 $57.15
DEBIT CARD SALES 0 $0.00 0 $0.00 0 $0.00 $0.00
GIFT CERTIFICATES 0 $0.00 0 $0.00 0 $0.00 $0.00
GIFT CARDS 0 $0.00 0 $0.00 0 $0.00 $0.00
INCOMING WIRE SALES 9 $505.96 1 $43.00 10 $548.96 $54.90

STORE TOTAL 13 $774.39 3 $139.45 16 $913.84 $57.12

Sales By Hour
12:00 AM  1:00 AM 0 $0.00 0 $0.00 0 $0.00 $0.00
 1:00 AM  2:00 AM 0 $0.00 0 $0.00 0 $0.00 $0.00
 2:00 AM  3:00 AM 0 $0.00 0 $0.00 0 $0.00 $0.00
 3:00 AM  4:00 AM 0 $0.00 0 $0.00 0 $0.00 $0.00

SALES ANALYSIS
MARGIE'S FLOWERS

SALES ENTERED  02/18/2008 - 02/18/2008

Order Entry/Manual POS Total
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Delivery Analysis
Click the Delivery tab to display the Delivery Analysis report. The status of the sales scheduled for 
delivery is controlled by using the Designer or Delivery tools.

Figure 19-9: Business Snapshot – Delivery Analysis Report

The Delivery Analysis report contains the following information

Product Analysis
Click the Products tab to display the Product Analysis report.

Table 19-5: Delivery Analysis Report Field Descriptions

Column Description

Store Name Name of store selected in the Business Snapshot window. If you are set up 
with multiple stores, All Stores indicates that the report contains data for all 
stores.

Sales Scheduled for 
Delivery

Reporting period selected in the Business Snapshot window. The Delivery 
Analysis report shows deliveries scheduled for this period.

Order Entry/Manual Count and total value for deliveries for the reporting period that were 
entered or attached in Order Entry.

POS Count and total value for deliveries for the reporting period that were 
entered or attached in Point of Sale.

Total Total of count and total value for deliveries for the reporting period that 
were entered or attached in Order Entry and Point of Sale.

Average Average value of the total deliveries for the delivery status.

Not Designed Number and value of orders entered in Order Entry and POS that have not 
been designed, marked as on a truck, or marked as delivered.

Designed Number and value of orders entered in Order Entry and POS that have been 
designed, but not marked as on a truck or delivered.

On the Truck Number and value of orders entered in Order Entry and POS that have been 
designed and are marked as on a truck, but which have not been marked as 
delivered.

Delivered Number and value of orders entered in Order Entry and POS that have been 
marked as delivered.

Count Total Count Total Count Total Average
Delivery Status
Karen's Flower Shop
NOT DESIGNED 13 $1,094.93 39 $3,732.31 52 $4,827.24 $92.83
DESIGNED 1 $60.75 0 $0.00 1 $60.75 $60.75
ON THE TRUCK 0 $0.00 0 $0.00 0 $0.00 $0.00
DELIVERED 16 $1,747.16 1 $1,434.08 17 $3,181.24 $187.13

STORE TOTAL 30 $2,902.84 40 $5,166.39 70 $8,069.23 $115.27

DELIVERY ANALYSIS
All Stores

SALES SCHEDULED FOR DELIVERY 08/01/2005 - 08/02/2005

Order Entry/Manual POS Total
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Figure 19-10: Business Snapshot – Product Analysis Report

The Product Analysis report contains the following information

Table 19-6: Product Analysis Report Field Descriptions

Column Description

Store Name Name of store selected in the Business Snapshot window. If you are set up 
with multiple stores, All Stores indicates that the report contains data for all 
stores.

Products Scheduled for 
Delivery

Reporting period selected in the Business Snapshot window. The Product 
Analysis report shows products scheduled for delivery for this period.

Local & Deliveries Count and total value for the reporting period of products scheduled for 
local sales and deliveries. The products for these scheduled deliveries will 
come out of the store’s inventory.

Outgoing Count and total value of products for the reporting period scheduled for 
outgoing deliveries. These scheduled deliveries do not affect the store’s 
inventory.

Total Count and total value of products for the reporting period scheduled for 
both local sales and deliveries and outgoing deliveries.

Average Average value of the product category or code for the reporting period for 
both local sales and deliveries and outgoing deliveries.

Product Category Sales Summarizes the count and value for products scheduled for Local/Delivery 
and Outgoing delivery by the product sales categories you assigned to 
products in Product Maintenance. 

Product Sales Shows the count and value for products scheduled for Local/Delivery and 
Outgoing delivery by the product code. 

Count Total Count Total Count Total Average
Product Category Sales
Karen's Flower Shop
Perishables 57 $3,145.00 0 $0.00 57 $3,145.00 $55.18
Container 0 $0.00 0 $0.00 0 $0.00 $0.00
Plush 9 $90.00 0 $0.00 9 $90.00 $10.00
Cards 19 $66.50 0 $0.00 19 $66.50 $3.50
Other 52 $2,872.69 6 $186.95 58 $3,059.64 $52.75
Silk 3 $128.00 0 $0.00 3 $128.00 $42.67
Wedding 0 $0.00 0 $0.00 0 $0.00 $0.00
Balloons 30 $82.50 0 $0.00 30 $82.50 $2.75
Candy 16 $210.00 0 $0.00 16 $210.00 $13.13
Gourmet 8 $604.00 0 $0.00 8 $604.00 $75.50
Fruit Baskets 5 $265.00 0 $0.00 5 $265.00 $53.00

STORE TOTAL 199 $7,463.69 6 $186.95 205 $7,650.64 $37.32

Product Sales
Karen's Flower Shop
Blooming Plants 8 $415.00 0 $0.00 8 $415.00 $51.88
Bouquet 3 $220.00 0 $0.00 3 $220.00 $73.33
Candy 8 $90.00 0 $0.00 8 $90.00 $11.25
Dozen Roses 5 $375.00 0 $0.00 5 $375.00 $75.00
Dried Silks 1 $23.00 0 $0.00 1 $23.00 $23.00
Fresh Arrangement 41 $2,135.00 0 $0.00 41 $2,135.00 $52.07
Fresh Fruit Basket 5 $265.00 0 $0.00 5 $265.00 $53.00
FTD Belgian Chocolate Gift 8 $120.00 0 $0.00 8 $120.00 $15.00
FTD Big Hug Bouquet 2 $80.00 0 $0.00 2 $80.00 $40.00
FTD Friends n Such Bouquet 1 $50.00 0 $0.00 1 $50.00 $50.00
FTD Sweet Dreams Boy Bouquet 3 $150.00 0 $0.00 3 $150.00 $50.00
FTD Sweet Dreams Girl Bouquet 1 $50.00 0 $0.00 1 $50.00 $50.00
FTD Sweet Surprise Bouquet 3 $150.00 0 $0.00 3 $150.00 $50.00
FTD Thanks A Bunch Bouquet 4 $150.00 0 $0.00 4 $150.00 $37.50
Gift C tifi t 5 $430 00 0 $0 00 5 $430 00 $86 00

PRODUCT ANALYSIS
All Stores

PRODUCTS SCHEDULED FOR DELIVERY 08/01/2005 - 08/02/2005

LOCAL & DELIVERIES OUTGOING Total
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Wire Analysis
Click the Wire tab to display the Wire Analysis report.

Figure 19-11: Business Snapshot – Wire Analysis Report

The Wire Analysis report contains the following information.

Generating the Business Snapshot Report
TASK To generate the Business Snapshot report:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click Mercury Forms.
3 Double-click on the Business Snapshot Report icon to open the template.
4 If a window opens asking whether you wish to enable or disable macros, click Enable Macros.

Table 19-7: Wire Analysis Report Field Descriptions

Column Description

Store Name Name of store selected in the Business Snapshot window. If you are set up 
with multiple stores, All Stores indicates that the report contains data for all 
stores.

Sales Entered Reporting period selected in the Business Snapshot window. The Wire 
Analysis report shows incoming and outgoing wire sales for this period.

Order Entry/Manual Count and total value for incoming and outgoing wire sales for the reporting 
period that were attached in Order Entry. Values include product and 
delivery charges, but no fees or service charges.

POS Count and total value for incoming and outgoing wire sales for the reporting 
period that were attached in Point of Sale. Values include product and 
delivery charges, but no fees or service charges.

Total Total of count and total value for incoming and outgoing wire sales for the 
reporting period that were attached in Order Entry and Point of Sale. Values 
include product and delivery charges, but no fees or service charges.

Average Average value of the total for incoming and outgoing wire sales.

Incoming Shows the count and value for incoming wire sales for the reporting period 
that were attached in Order Entry, Point of Sale, and total by wire services.

Outgoing Shows the count and value for outgoing wire sales for the reporting period 
that were attached in Order Entry, Point of Sale, and total by the wire 
services.

Count Total Count Total Count Total Average
Orders By Wire Service
INCOMING
FTD 7 $421.96 0 $0.00 7 $421.96 $60.28
TEL 1 $49.99 0 $0.00 1 $49.99 $49.99
Other 2 $84.00 1 $43.00 3 $127.00 $42.33

STORE TOTAL 10 $555.95 1 $43.00 11 $598.95 $54.45

OUTGOING
FTD 0 $0.00 0 $0.00 0 $0.00 $0.00
TEL 0 $0.00 0 $0.00 0 $0.00 $0.00
Other 0 $0.00 0 $0.00 0 $0.00 $0.00

STORE TOTAL 0 $0.00 0 $0.00 0 $0.00 $0.00

WIRE ANALYSIS
MARGIE'S FLOWERS

SALES ENTERED  02/18/2008 - 02/18/2008

Order Entry/Manual POS Total
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5 Select a store, a date range of sale data to include, and then click Finish. The report takes a few 
seconds to populate with data.

Business Snapshot Window
The Business Snapshot window allows you to configure settings for the Business Snapshot report. 
When you are finished configuring settings, click Finish to generate the report and open it in 
Microsoft Excel.

Figure 19-12: Business Snapshot Window

The Business Snapshot window contains the following settings.

Credit Card Settlement History Report
The Credit Card Settlement History report lists your credit card settlements for the given date 
range. The report also prints the settlement number, date, approval or error codes, and dollar 
amounts.

» The Detail Report lists each settlement, including each credit card authorization in the 
settlement. Totals are listed for each settlement, and grand totals for each store.

» The Summary Report lists each settlement, totals for each settlement, and grand totals for 
each store.

Generating the Credit Card Settlement History Report
TASK To generate the Credit Card Settlement History report:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click Mercury Forms.
3 Double-click on the Credit Card Settlement History icon to open the template.

Table 19-8: Business Snapshot Window Settings

Setting Description

Select Store Select the store for which you are generating the Business Snapshot. If you are 
set up with multiple stores, you can also select All Stores to generate a combined 
Business Snapshot.

Start Date The date for the beginning of the period on which you are reporting.

End Date The date for the end of the period on which you are reporting.
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4 If a window opens asking whether you wish to enable or disable macros, click Enable Macros.
5 In the Select Store field, click the arrow and select the store for which you want to print credit 

card information.
6 In the Date Range section, click the down arrows to select the start date and the end date.
7 In the Report Type section, select if you want to print the Detail Report or Summary Report.
8 Click Finish. The report generates and opens in Excel.
9 To print your report from Excel, on the File menu, click Print.
10 If you want to save the report from Excel, on the File menu, click Save.

Figure 19-13: Credit Card Settlement History Report - Detail
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Figure 19-14: Credit Card Settlement History Report - Summary

Credit Card Settlement History Window
The Credit Card Settlement History window allows you to configure settings for the Credit Card 
Settlement History report.

Figure 19-15: Credit Card Settlement History Window

The Credit Card Settlement History window contains the following settings.

Table 19-9: Credit Card Settlement History Window Settings

Setting Description

Select Store Select the store for which you want to generate the report. If you have multiple 
stores, you can select All Stores to generate a report that includes data from all of 
your stores.

Date Range Select the start and end dates for the report.
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Customer Account Payment Report
The Customer Account Payment report lists all payments made on house accounts within the 
given date range. The report is listed by customer ID. Grand totals by payment method are also 
listed at the bottom of the report.

» The Detail Report lists each customer that made a payment within the specified date range, as 
well as each individual payment, the payment method, the payment date, and the payment 
amount. A total is also listed for each customer.

» The Summary Report lists each customer that made a payment within the specified date 
range, and the total amount that the customer has paid.

Generating the Customer Account Payment Report
TASK To generate the Customer Account Payment report:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click Mercury Forms.
3 Double-click on the Customer Account Payments Report icon to open the template.
4 If a window opens asking if you wish to enable macros, click Enable Macros.
5 In the Select Store field, click the arrow and select the store’s data that you want to use for the 

report.
6 In the Report Type section, select if you want to print the Detail Report or Summary Report.
7 In the Sort Option section, select if you want to sort the report by Payment Type or Date.
8 In the Date Range section, select a start and end date for the data that you want to include in 

the report. These dates are the dates that the payment was entered into the system.
9 Click Finish. The report generates and opens in Excel.
10 To print your report from Excel, on the File menu, click Print.
11 If you want to save the report from Excel, on the File menu, click Save.

Report Type Select whether you want to generate a summary or detail report.

Table 19-9: Credit Card Settlement History Window Settings (cont.)

Setting Description
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Figure 19-16: Customer Account Payments Report - Detail
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Figure 19-17: Customer Account Payments Report - Summary

Customer Account Payments Window
The Customer Account Payments window allows you to configure settings for the Customer 
Account Payment report. When you have finished configuring settings, click Finish to generate the 
report. It will open in Microsoft Excel.

Figure 19-18: Customer Account Payments Window
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The Customer Account Payments window contains the following settings.

Customer Master List 
The Customer Master List provides you with a list of all your customers, as well as their current 
balance information, and house account information such as their credit limit and discount 
amount. This report may take several minutes to print, depending on the size of your customer 
database.

Table 19-10: Customer Account Payments Window Settings

Setting Description

Select Store Select the store for which you want to generate the report. If you have multiple 
stores, you can select All Stores to generate a report that includes data from all of 
your stores.

Report Type Select whether you want to generate a summary or detail report.

Sort Option For detailed reports, select whether you want the report sorted by date or 
payment type.

Date Range Select the start and end dates for the report.
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Figure 19-19: Customer Master List

Generating the Customer Master List
TASK To generate the Customer Master List:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click Mercury Forms.
3 Double-click on the Customer Master icon to open the template.
4 If a window opens asking whether you wish to enable or disable macros, click Enable Macros.
5 If you receive the message “This application is about to initialize ActiveX controls...” click OK.
6 In the Store of Origin field, click the arrow and select the store’s data that you want to use for 

the report.
7 In the Please select payment type section, click in the check boxes so check marks appear for 

any combination of payment types you wish to include in this report.
8 If you want to print customers with particular marketing types, click Marketing Criteria 

Selection so that a check mark appears (otherwise leave this option unchecked). This allows 
you to filter customer information so that, for example, you can print only Business accounts in 
the report. (If this area is blank, it means that you have no marketing categories set up. See 
Marketing Screen on page 24–21 for information on setting up these categories.)
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To select marketing categories to print, first click on a category so that a drop-down arrow 
displays. Click this arrow to display a drop-down list of marketing types. Then check which 
types you want to print.
To print only customers with no marketing information specified in the Customer Detail 
Information window, first check the Marketing Criteria Selection option so that a check mark 
appears, then check Customers with No Marketing Criteria.

9 In the Sort Option section, choose whether you wish to list customers according to Default Pay 
Method, Last Purchase Date, or Name. If you select to sort by last purchase date, specify the 
last purchase date by clicking the down arrow in the date field and selecting the date from the 
calendar.

10 Click Finish. The report generates and opens in Excel.
11 To print your report from Excel, on the File menu, click Print.
12 If you want to save the report from Excel, on the File menu, click Save.

Customer Master List Window
The Customer Master List window enables you to configure settings for the Customer Master List 
report. When you have finished configuring the settings, click Finish to generate the report. It will 
open in Microsoft Excel.

Figure 19-20: Customer Master List Window
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The Customer Master List window contains the following settings.

Employee Analysis Report
The Employee Analysis report allows you to print productivity reports for your clerk, designer, and 
driver employee types. These reports allow you to see how each of your employees have 
performed for a given date range. For example, you can generate reports that print which products 
your employees have sold, designed, or delivered including average dollar amounts, discounts 
given, number of items, etc. 

Following are examples of some variations of the report:

The Clerk – Summary report lists products sold by product category and includes the quantities 
and dollar amounts:

Figure 19-21: Employee Analysis – Clerk Summary

The Clerk – Detail report lists the individual products sold, which are totaled for each product 
category:

Table 19-11: Customer Master List Window Settings

Setting Description

Store of Origin From this list, select the store with which the customer is associated. If you have 
multiple stores, you can select All Stores.

Payment Types Select the payment type(s) you want to include in the report. You can select 
Cash, Check, Credit, Debit, House, or Gift Certificate.

Marketing Criteria 
Selection

If you select this option, you can filter the report so it includes customers with 
specific marketing criteria or no marketing criteria. If you select Customers with 
Marketing Criteria, you can select the marketing categories to include.

Sort Option You can select to sort the report by the Default Pay Method, the Last Purchase 
Date (requires you specify the date), or by Name.

Employee Product Total Average
Product Code Items Amount Discounts Amount Amount
Administrator

Balloons 6 2.00 0.00 12.00 2.00
Candy 8 25.00 0.00 115.00 14.38
Cards 4 3.50 0.00 14.00 3.50
Fee 3 106.08 0.00 113.08 37.69
Fruit Baskets 3 50.00 0.00 150.00 50.00
Gourmet 1 75.00 0.00 75.00 75.00
Other 3 115.00 0.00 180.00 60.00
Perishables 14 228.00 0.00 755.00 53.93
Plush 2 10.00 0.00 20.00 10.00

Employee Total 44 614.58 0.00 1,434.08 32.59

Jennifer
Cards 2 3.50 0.00 7.00 3.50
Fee 2 21.64 0.00 21.64 10.82
Gourmet 1 75.00 0.00 75.00 75.00
Oth 1 40 00 0 00 40 00 40 00

07/29/2005 - 07/29/2005

Employee Analysis
Clerk - Inventory

Summary - Sale Date
All Stores
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Figure 19-22: Employee Analysis – Clerk Detail

The Designer – Summary report lists products designed by product category and includes the 
quantities and dollar amounts:

Employee Product Total Average
Product Code Items Amount Discounts Amount Amount
Jennifer
Fee
RELAY IL Sales Tax 1 7.50 0.00 7.50 7.50
Employee Category Total 1 7.5 0 7.5 7.5
Other
V2 The FTD Sweethearts Bouquet 1 34.99 0.00 34.99 34.99
Employee Category Total 1 34.99 0 34.99 34.99
Perishables
ARR Fresh Arrangement 3 50.00 0.00 150.00 50.00
BPL Blooming Plants 1 50.00 0.00 50.00 50.00
Employee Category Total 4 100 0 200 50
Plush
TB Teddy Bear 1 10.00 0.00 10.00 10.00
Employee Category Total 1 10 0 10 10

Employee Total 7 152.49 0.00 252.49 36.07

Lisa
Candy
CFC Candy 1 10.00 0.00 10.00 10.00
E l C t T t l 1 10 0 10 10

08/02/2005 - 08/02/2005

Employee Analysis
Clerk - Inventory

Detail - Sale Date
All Stores



Employee Analysis Report 19–27

Figure 19-23: Employee Analysis – Designer Summary

The Designer – Detail report lists the individual products designed, which are totaled for each 
product category:

Figure 19-24: Employee Analysis – Designer Detail

The Driver – Summary report lists products delivered by product category and includes the 
quantities and dollar amounts:

Employee Product Total Average
Product Code Items Amount Discounts Amount Amount
Karen

Fruit Baskets 1 50.00 0.00 50.00 50.00
Gourmet 1 75.00 0.00 75.00 75.00
Other 1 40.00 0.00 40.00 40.00
Perishables 5 295.00 0.00 345.00 69.00

Employee Total 8 460.00 0.00 510.00 63.75

Leslie
Other 2 100.00 0.00 100.00 50.00
Perishables 17 228.00 0.00 930.00 54.71

Employee Total 19 328.00 0.00 1,030.00 54.21

Grand Total 27 788.00 0.00 1,540.00 57.04

07/28/2005 - 08/02/2005

Employee Analysis
Designer - Inventory

Summary - Delivery Date
All Stores

Employee Product Total Average
Product Code Items Amount Discounts Amount Amount
Karen
Fruit Baskets
FRT Fresh Fruit Basket 1 50.00 0.00 50.00 50.00
Employee Category Total 1 50 0 50 50
Gourmet
GMT Gourmet Basket 1 75.00 0.00 75.00 75.00
Employee Category Total 1 75 0 75 75
Other
BH FTD Big Hug Bouquet 1 40.00 0.00 40.00 40.00
Employee Category Total 1 40 0 40 40
Perishables
ARR Fresh Arrangement 1 75.00 0.00 75.00 75.00
BOU Bouquet 1 120.00 0.00 120.00 120.00
Employee Category Total 2 195 0 195 97.5

07/29/2005 - 07/29/2005

Employee Analysis
Designer - Inventory
Detail - Delivery Date

All Stores
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Figure 19-25: Employee Analysis – Driver Summary

The Driver – Detail report lists the individual products delivered, which are totaled for each 
product category:

Figure 19-26: Employee Analysis – Driver Detail

Generating the Employee Analysis Report
TASK To generate the Employee Analysis Report:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click Mercury Forms.
3 Double-click on the Employee Analysis icon to open the template.
4 If a window opens asking whether you wish to enable or disable macros, click Enable Macros.

Employee Product Total Average
Product Code Items Amount Discounts Amount Amount
Cathy

Fee 1 6.22 0.00 6.22 6.22
Fee 1 6.22 0.00 6.22 6.22
Other 1 32.99 0.00 32.99 32.99
Perishables 2 50.00 0.00 100.00 50.00
Perishables 2 50.00 0.00 100.00 50.00
Plush 1 10.00 0.00 10.00 10.00

Employee Total 8 155.43 0.00 255.43 31.93

Dan
Candy 1 10.00 0.00 10.00 10.00
Fee 1 6.37 0.00 6.37 6.37
Fee 1 6.37 0.00 6.37 6.37
Fee 1 6.37 0.00 6.37 6.37
Other 1 49.99 0.00 49.99 49.99
Other 1 49.99 0.00 49.99 49.99
Other 1 49.99 0.00 49.99 49.99
Perishables 1 50.00 0.00 50.00 50.00

Employee Total 8 229.08 0.00 229.08 28.64

08/02/2005 - 08/02/2005

Employee Analysis
Driver - Inventory

Summary - Delivery Date
All Stores

Employee Product Total Average
Product Code Items Amount Discounts Amount Amount
Cathy
Other
B1-3710 The FTD Tigress Bouquet - Novemb 1 32.99 0.00 32.99 32.99
Employee Category Total 1 32.99 0.00 32.99 32.99
Perishables
ARR Fresh Arrangement 2 50.00 0.00 100.00 50.00
Employee Category Total 2 50.00 0.00 100.00 50.00

08/02/2005 - 08/02/2005

Employee Analysis
Driver - Inventory

Detail - Delivery Date
All Stores
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5 In the Employee Type section, select if you would like to print the Clerk, Designer, or Driver 
analysis report. 

6 In the Report Type section, select if you would like to print the Detail Report or Summary 
Report.

7 In the Sale Type section, select if you would like to print Inventory sales (sales where the 
product from your inventory was used), Wire Out sales or Both.

8 In the Date Range section, select a Start Date and End Date for the data that you would like to 
include in the report. Select whether you want the report generated by Delivery Date or Sale 
Date.

9 Click Finish. The report generates and opens in Excel.
10 To print your report from Excel, on the File menu, click Print.
11 If you want to save the report from Excel, on the File menu, click Save.

Employee Production Report Window
The Employee Production Report windows allows you to configure settings for the Employee 
Analysis report. When you have finished configuring settings, click Finish to generate the report. It 
will open in Microsoft Excel.

Figure 19-27: Employee Production Report Window

The Employee Production Report window contains the following settings.

Table 19-12: Employee Production Report Window Settings

Setting Description

Select Store Select the store for which you want to generate the report. If you have multiple 
stores, you can select All Stores to generate a report that includes data from all of 
your stores.
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Employee Sales Report
You may monitor your employees’ sales activity by printing an Employee Sales report. This report 
displays an order count and total dollar amount of orders for each employee for a given sales date 
range. The following steps teach you how to print an Employee Sales Report.

Generating the Employee Sales Report
TASK To generate an Employee Sales report:

1 In FTD Mercury, from the Management menu, click Employee Sales Summary. The Employee 
Sales Report window opens.

2 At the top of the window, click whether you want to display Daily Sales Data, Weekly Sales 
Data, or Monthly Sales Data. For example, if you print Weekly Sales Data for the month of April, 
FTD Mercury displays the total order count and dollar amount for each week in April (see 
example below).

3 In the Employee Name field, click the arrow and select the employee for whom you want to 
display sales information.

4 In the Select Date Range section, use the down arrows to select a to and from date for the sales 
for which you want to display statistics.

5 Click Search.
6 To print your report, click Print. The report will print to the printer selected for General Printing 

in Tools > Printer Form Settings.

Figure 19-28: Employee Sales Report (Weekly Sales Data)

Employee Type Select the type of employee for which you are generating the report. You can 
select Clerk, Designer or Driver.

Report Type Select whether you want to generate a summary or detail report.

Sale Type Select whether you want the report to include sales from your inventory, wire out 
sales, or both.

Date Range Select the start and end dates for the report.

Delivery or Sale Date Select whether the report will be based on delivery or sale dates.

Table 19-12: Employee Production Report Window Settings (cont.)

Setting Description
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Employee Sales Report Window
The Employee Sales Report window allows you to configure settings for the Employee Sales Report. 

Figure 19-29: Employee Sales Report Window

The Employee Sales Report window contains the following settings.

Message Report
The Message Report lists all orders and messages that you have sent or received during the time 
period you specify.

Table 19-13: Employee Sales Report Window Settings

Setting Description

Daily, Weekly, Monthly 
Sales Data

Select the period for which you want to see the employee’s sales data.

Employee Name Select the employee whose data you are reporting.

Date Range Use the drop-down calendars to select the start and end dates for sales to be 
included in the report. 
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Figure 19-30: Message Report

Generating the Message Report
TASK To generate the Message report:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click Mercury Forms.
3 Double-click on the Message Report icon to open the template.
4 If a window opens asking whether you wish to enable or disable macros, click Enable Macros.
5 When the Message Report window opens:

a. Click the arrow in the Start Date field to display a calendar. Use your mouse to click on the 
date from which your system will begin to list messages.

b. Click the arrow in the End Date field to display a calendar. Use your mouse to click on the 
date that your system will end listing messages.

c. Click Finish. The report generates and opens in Excel.
6 To print your report from Excel, on the File menu, click Print.
7 If you want to save the report from Excel, on the File menu, click Save.

Message Report Window
The Message Report window allows you to configure the message date range for the Message 
Report. Click Finish to generate the report and open it in Microsoft Excel.

Figure 19-31: Message Report Window
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The Message Report window contains the following settings.

Payment Type Totals Report
The Payment Type Totals report lists all payments made by your customers, within a specified date 
range. Data is sorted by payment type (cash, credit card, house, check, debit card, gift card, and gift 
certificate).

Figure 19-32: Payment Type Totals Report

Generating the Payment Type Totals Report
TASK To generate the Payment Type Totals report:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click Mercury Forms.
3 Double-click on the Payment Type Totals icon to open the template.
4 If a window opens asking whether you wish to enable or disable macros, click Enable Macros.
5 In the Select Store field, click the arrow and select the store’s data that you want to use for the 

report.
6 In the Start Date field of the Sale Date Range area, click the arrow to display a calendar. Use 

your mouse to click on the date from which your system will start listing payment type totals.
7 In the End Date field, click the arrow to display a calendar. Use your mouse to click on the date 

that your system will end listing payment type totals.
8 Click Finish. The report generates and opens in Excel.
9 To print your report from Excel, on the File menu, click Print.
10 If you want to save the report from Excel, on the File menu, click Save.

Payment Type Totals Window
The Payment Type Totals window allows you to configure settings for the Payment Type Totals 
report. When you have finished configuring settings, click Finish to generate the report. It will open 
in Microsoft Excel.

Table 19-14: Message Report Window Settings

Setting Description

Start Date Enter the starting date for the report.

End Date Enter the ending date for the report

Date Amount Count Amount Count Amount Count Amount Count Amount Count Amount Count Amount Count Amount Count

02/06/2008 93.95 3 877.14 13 1,781.65 32 0.00 0 0.00 0 0.00 0 0.00 0 0.00 0
02/07/2008 130.85 3 497.00 11 5,399.20 87 193.00 3 0.00 0 0.00 0 0.00 0 0.00 0
02/08/2008 181.24 6 409.40 9 2,614.55 44 0.00 0 0.00 0 0.00 0 0.00 0 0.00 0
02/09/2008 0.00 0 326.63 6 806.84 15 0.00 0 0.00 0 0.00 0 0.00 0 0.00 0
02/10/2008 25.00 1 111.89 3 1,179.79 20 0.00 0 0.00 0 0.00 0 0.00 0 0.00 0
02/11/2008 0.00 0 1,703.22 24 6,072.25 89 0.00 0 0.00 0 0.00 0 0.00 0 0.00 0
02/12/2008 219.95 5 1,558.43 25 6,609.94 100 0.00 0 0.00 0 0.00 0 0.00 0 0.00 0
02/13/2008 258.35 10 2,905.99 52 12,428.67 190 0.00 0 0.00 0 0.00 0 0.00 0 0.00 0
02/14/2008 731.98 38 2,165.44 52 3,409.89 56 0.00 0 0.00 0 0.00 0 0.00 0 0.00 0
02/15/2008 36.80 2 281.35 5 2,273.08 42 0.00 0 0.00 0 0.00 0 0.00 0 0.00 0

   Gift Certificate  Debit Card   Cash   Credit Card     House  Check Write-OffGift Card
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Figure 19-33: Payment Type Totals Window

The Payment Type Totals window contains the following settings.

Product Comparison Report
The Product Comparison report allows you to view a comparison of two sales date ranges or the 
same sales date range for two stores. For example, you may want to compare Valentine’s Day sales 
from last year to this year. Or you may want to compare two stores’ performance on a certain day. 
Detail and Summary reports can be printed. The Detail report compares sales by product code and 
product category, while the Summary report compares sales by product category only.

The Product Comparison – Date Range Summary Report compares data by product category:

Figure 19-34: Product Comparison – Date Range Summary Report

Table 19-15: Payment Type Totals Window Settings

Setting Description

Select Store Select the store for which you want to generate the report. If you have multiple 
stores, you can select All Stores to generate a report that includes data from all of 
your stores.

Sale Date Range Enter the start and end dates for the report.

Sales Sales Sales
Prod Code Total Items Amount Items Amount Items Amount % - Change

Balloons 18 12.00 6 34.00 12 22.00 64.7%
Candy 14 115.00 8 75.00 6 -40.00 -53.3%
Cards 8 24.50 7 3.50 1 -21.00 -600.0%
Fee 9 28.00 4 35.00 5 7.00 20.0%
Fruit Baskets 6 200.00 4 100.00 2 -100.00 -100.0%
Gourmet 5 225.00 3 150.00 2 -75.00 -50.0%
Other 13 270.00 5 383.96 8 113.96 29.7%
Perishables 36 1,500.00 26 600.00 10 -900.00 -150.0%
Plush 8 30.00 3 50.00 5 20.00 40.0%
Silk 1 0.00 0 120.00 1 120.00 100.0%

Grand Total: 118 2,404.50 66 1,551.46 52 -853.04 -55.0%

VARIANCES

PRODUCT COMPARISON REPORT
Summary by Date Range

07/28/2005 - 07/28/2005 Compared to 08/02/2005 - 08/02/2005
Inventory Sales

Karen's Flower Shop
08/02/2005 - 08/02/2005

Karen's Flower Shop
07/28/2005 - 07/28/2005
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The Product Comparison – Date Range Detail Report compares data on a product code level. The 
product codes are also totaled out by product category:

Figure 19-35: Product Comparison – Date Range Detail Report

Generating a Product Comparison Report
TASK To print the Product Comparison report:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click Mercury Forms.
3 Double-click on the Product Comparison Report icon to open the template.
4 If a window opens asking whether you wish to enable or disable macros, click Enable Macros.
5 Specify the information that you want to compare:

» Select Store – Select a store. If you are comparing data between stores, you will select the 
second store in the next field.

» Comparison Type – If you are comparing two dates or date ranges, select Date. If you are 
comparing two store’s data for a given date or date range, select Store and then select the 
store in the drop-down list. 

» Report Type – Select if you want to print the Detail or Summary report. The Detail report 
lists totals by product category. The Summary report lists totals by product code.

Sales Sales Sales
Prod Code Name Total Items Amount Items Amount Items Amount % - Change

Balloons
LBLN Latex Balloon 14 12.00 6 16.00 8 4.00 25.0%
MBLN Mylar Balloons 4 0.00 0 18.00 4 18.00 100.0%

Category Total: 18 12.00 6 34.00 12 22.00 64.7%

Candy
BC FTD Belgian Chocolate Gift 10 105.00 7 45.00 3 -60.00 -133.3%
CFC Candy 4 10.00 1 30.00 3 20.00 66.7%

Category Total: 14 115.00 8 75.00 6 -40.00 -53.3%

Cards
CAR Greeting Card 8 24.50 7 3.50 1 -21.00 -600.0%

Category Total: 8 24.50 7 3.50 1 -21.00 -600.0%

Fee
DELIV Delivery Charge 9 28.00 4 35.00 5 7.00 20.0%

Category Total: 9 28.00 4 35.00 5 7.00 20.0%

Fruit Baskets
FRT Fresh Fruit Basket 6 200.00 4 100.00 2 -100.00 -100.0%

Category Total: 6 200.00 4 100.00 2 -100.00 -100.0%

Gourmet
GMT Gourmet Basket 5 225.00 3 150.00 2 -75.00 -50.0%

Category Total: 5 225.00 3 150.00 2 -75.00 -50.0%

Other
B1-3710 The FTD Tigress Bouquet - November 1 0.00 0 32.99 1 32.99 100.0%
gc Gift Certificate 3 130.00 2 100.00 1 -30.00 -30.0%
BH FTD Big Hug Bouquet 3 40.00 1 80.00 2 40.00 50.0%
MM FTD Sweet Surprise Bouquet 2 50 00 1 50 00 1 0 00 100 0%

VARIANCES

PRODUCT COMPARISON REPORT
Detail by Date Range

07/28/2005 - 07/28/2005 Compared to 08/02/2005 - 08/02/2005
Inventory Sales

Karen's Flower Shop
08/02/2005 - 08/02/2005

Karen's Flower Shop
07/28/2005 - 07/28/2005
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» Sale Type – Select if you want to include Inventory sales, Wire Out sales, or Both.

» Date Range – Specify the sales date range you want to compare. If you are comparing two 
stores’ data, this is the date range that you are comparing between the two stores.

» Comparison Dates – This field is active only if you are comparing dates ranges for the same 
store. Specify the date range that you want to compare to the first date range.

6 Click Finish. The report generates and opens in Excel.
7 To print your report from Excel, on the File menu, click Print.
8 If you want to save the report from Excel, on the File menu, click Save.

Product Comparison Report Window
The Product Comparison Report window enables you to configure settings for the Product 
Comparison report.When you are finished configuring settings, click Finish to generate the report 
and open it in Microsoft Excel.

Figure 19-36: Product Comparison Report Window

The Product Comparison Report window contains the following settings.

Table 19-16: Product Comparison Report Window Settings

Setting Description

Select Store Select the store for the report. If you are comparing data between two stores, you 
select the second store in the Comparison Type area.

Comparison Type Select whether you want to generate a comparison report by date or by store. If 
you select Store, choose the store you are comparing the store in the Select Store 
list against.
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Product Sales Reports
The Product Sales Reports provide you with an analysis of which products are selling and how 
many are being sold either in-house, outgoing, or both. There are three different types of sales 
analysis reports: Product List, Sales by Product Code, and Sales by Date, Occasion, and Product. 
Each type has a summary report and a a detail report.

NOTE It is possible for the same product to be listed more than once on the Sales by Product Code and Sales by 
Date, Occasion, and Product reports if that product was sold under different occasion types.

List of Product Codes Summary Report
The Product List – Summary report lists the products that you have in your product database.

Report Type Select whether you want to generate a Detail Report or a Summary Report.

Sale Type Select whether you want to include Inventory sales, Wire Out sales, or Both.

Date Range Specify the sales date range you want to compare. If you are comparing data 
from two stores, this is the sales date range you are comparing between the two 
stores.

Comparison Dates This area is only enabled if you are comparing date ranges from the same store. 
Specify the date range you want to compare to the values set in the Date Range 
area.

Table 19-16: Product Comparison Report Window Settings (cont.)

Setting Description



Chapter 19
Business Reports

19–38

Figure 19-37: Product Sales Report – Product List – Summary

List of Product Codes Detail Report
The List of Product Codes Detail report contains detail product information, such as quantities on 
hand, prices, and tax codes.

Prod Code Product Name Description 

A1 The FTD Fall Harvest Bouquet
A2 The FTD Autumn Splendor Bouquet
AB FTD Anniversary Bouquet

ADJUST_WEB ONLINE ADJUSTMENT
ARR Fresh Arrangement
B1 The FTD Bosses' Day Bouquet

B1-3700 The FTD Winter Elegance Bouquet - January
B1-3701 The FTD Pink Lily Bouquet - February
B1-3702 The FTD Morning Joy Bouquet - March
B1-3703 The FTD First Blooms Bouquet - April
B1-3704 The FTD Peak Of Freshness Bouquet - May
B1-3705 The FTD Happiness Bouquet - June
B1-3706 The FTD Rose Fest Bouquet - July
B1-3707 The FTD Burst Of Summer Bouquet - August
B1-3708 The FTD Garden Gate Bouquet - September
B1-3709 The FTD Fireburst Bouquet - October
B1-3710 The FTD Tigress Bouquet - November
B1-3711 The FTD Winterfresh Bouquet - December

B10-3446 The FTD Crimsom & Evergreen Wreath
B10-3720 The FTD Holiday Gold Wreath
B10-3721 The FTD Beacon Hill Wreath
B10-3722 The FTD Sleigh Ride Arrangement
B10-3723 The FTD Glad Tidings Tree
B10-3724 The FTD Holiday Classics Garland
B11-2921 The FTD Lights of the Season Centerpiece
B12-3099 The FTD Festive Season Arrangement
B12-3254 The FTD Festival of Lights Arrangement
B12-3734 The FTD Feast of Light Centerpiece
B13-3501 The FTD Fresh as a Daisy Bouquet
B13-3510 The FTD Spring Glory Centerpiece
B13-3736 The FTD Easter Delights Centerpiece
B13-3737 The FTD Spring Enchantment Bouquet
B14-3229 The FTD Pink Splendor Bouquet
B14-3230 The FTD Raspberry Patch Arrangement
B14-3598 The FTD Smooth Jazz Bouquet
B15-3735 The FTD Joy of Spring Bouquet
B16-3227 The FTD Friendly Welcome Arrangement
B16-3228 The FTD Carnival Bouquet
B16-3738 The FTD Garden Spring Basket
B16-3739 The FTD Spirit of Spring Basket
B16-3740 The FTD Hint of Spring Bouquet
B16-9143 The FTD Easter Lily Plant
B17-3487 The FTD Springtime Jubilee Bouquet
B18-3226 The FTD Basket Of Stars Bouquet
B18-3741 The FTD Summer Medley Bouquet
B18-3742 The FTD Fun in the Sun Basket
B19-3263 The FTD Celebration of Life Bouquet
B19-3466 The FTD Daylight Bouquet
B2-2901 The FTD Autumn Beauty Bouquet

List of Product Codes Summary
All Store Locations

Start to End
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Figure 19-38: Product Sales Report – Product List – Detail

Sales by Product Code Summary Report
The Sales by Product Code – Summary report lists inventory, wire out, and total sales by product 
category for a specified sales or delivery date or date range. 

Figure 19-39: Product Sales Report – Sales by Product Code – Summary

Sales by Product Code Detail Report
The Sales by Product Code – Detail report is sorted by product category. Totals are provided for 
each product category:

Prod Code Product Category/Product Name Qty On Hand Tax GL Account # Price Additional Prices

Fee
ADJUST_WEB ONLINE ADJUSTMENT No Tax $0.00
DELIV Delivery Charge Tax Exempt $0.00
RELAY Relay Fee Tax Exempt $7.95
RETRANS Retrans Fee Tax Exempt $0.00
SERVICE Service Charge Tax Exempt $0.00
SYS_DELIVERYSYS_DELIVERY $0.00
SYS_RELAY SYS_RELAY $0.00
SYS_RETRANSSYS_RETRANS $0.00
SYS_SERVICE SYS_SERVICE $0.00

Other
**Gift Card **Gift Card $0.00 $0.00 $0.00
A1 The FTD Fall Harvest Bouquet 1 $39.99
A2 The FTD Autumn Splendor Bouquet 1 $49.99
B1 The FTD Bosses' Day Bouquet 1 $39.99
B1-3700 The FTD Winter Elegance Bouquet - Jan 1 $30.99
B1-3701 The FTD Pink Lily Bouquet - February 1 $33.99
B1-3702 The FTD Morning Joy Bouquet - March 1 $30.99
B1-3703 The FTD First Blooms Bouquet - April 1 $31.99
B1-3704 The FTD Peak Of Freshness Bouquet - 1 $31.99
B1-3705 The FTD Happiness Bouquet - June 1 $31.99

List of Product Codes Detail
MARGIE'S FLOWERS

Start to End
All Categories

Sales Sales Sales
Category Name Amount Items %-Sales Amount Items %-Sales Amount Items %-Sales

Karen's Flower Shop
CARDS 38.50 11 97.61 0.00 0 0.00 38.50 11 0.00
CONTAINERS 0.00 0 0.00 0.00 0 0.00 0.00 0 0.00
OTHER 590.00 11 63.32 0.00 0 0.00 590.00 11 0.00
PERISHABLE 940.00 15 41.56 0.00 0 0.00 940.00 15 0.00
PLUSH 40.00 4 97.51 0.00 0 0.00 40.00 4 0.00
STORE TOTAL 1,608.50 41 0.00 0.00 0 0.00 1,608.50 41 0.00
FEE 177.88 23 88.94 0.00 0 0.00 177.88 23 0.00

ALL STORES
GRAND TOTAL 1,608.50 41 0.00 0.00 0 0.00 1,608.50 41 0.00

Total SalesInventory Sales Wire Out Sales

Sales by Product Code 
All Stores

07/27/2005 - 07/27/2005
Inventory and WireOut Sales - Summary
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Figure 19-40: Product Sales Report – Sales by Product Code – Detail

Product Sales Report by Date by Occasion by Product Summary Report

The Sales by Date, Occasion, and Product – Summary report lists inventory, wire out, and total 
sales by occasion for a specified sale or delivery date or date range.

Sales
Prod Code Name Description Amount Items %-Sales

MARGIE'S FLOWERS
Arrangements
a CENTERPIECE ARR. CENTERPIECE ARR. $1,899.61 47 3.82%
A-CON CONTAINER ARR CONTAINER ARR $1,573.35 31 3.16%

A-S SEASONAL ARR.

SEASONAL ARR.....tf 11-2�
Red Roses with white dendrobs�
Make very artsy looking $25.00 51 0.05%

A-V VASE ARR.

VASE ARR....from our web 
site......Elegant Tribute�
Customer would like white lilles $3,578.03 80 7.19%

AR-BV BUD VASE ARR. BUD VASE ARR. $45.00 2 0.09%
C-C COURSAGE COURSAGE $10.00 1 0.02%
Category Total $7,130.99 212 14.33%

Balloons
B-BA BALLOON BOUQUET BALLOON BOUQUET $90.00 18 0.18%
B-L LATEX BALLOON LATEX BALLOON $21.50 2 0.04%
B-M MYLAR BALLOON MYLAR BALLOON $66.00 8 0.13%
Category Total $177.50 28 0.36%

Blooming Plants
BP-AZ AZALEA AZALEA $69.94 2 0.14%
BP-BEG BEGONIA BEGONIA $24.50 1 0.05%
BP-BP BASKET PLANTERS BASKET PLANTERS $374.94 7 0.75%
BP-GEN BLOOMING PLANT- BLOOMING PLANT- $617.50 16 1.24%
BP-HYG HYDRANGEAS HYDRANGEAS $460.00 21 0.92%
BP-KAL KALANCHOE KALANCHOE $47.50 5 0.10%
BP-OR ORCHID ORCHID $89.00 1 0.18%
Category Total $1,683.38 53 3.38%

Sales by Product Code 

Total Sales

MARGIE'S FLOWERS
Sale Date 01/11/2008 - 02/11/2008

All Categories
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Figure 19-41: Product Sales Report – Sales by Date, Occasion, and Product – Summary

Product Sales Report by Date by Occasion by Product Detail Report

The Sales by Date, Occasion, and Product – Detail report is sorted by occasion:

Figure 19-42: Product Sales Report – Sales by Date, Occasion, and Product – Detail

Occasion
Sales Amt. % Sales Amt. % Sales Amt. %

MARGIE'S FLOWERS
Sympathy 6,685.01 13.9% 437.60 27.3% 7,122.61 14.3%
Illness 6,328.18 13.1% 230.99 14.4% 6,559.17 13.2%
Birthday 6,018.72 12.5% 70.00 4.4% 6,088.72 12.2%
Business Gifts 89.99 0.2% 0.00 0.0% 89.99 0.2%
Holiday 12,025.32 25.0% 171.98 10.7% 12,197.30 24.5%
Maternity 1,388.13 2.9% 175.94 11.0% 1,564.07 3.1%
Anniversary 1,335.84 2.8% 40.00 2.5% 1,375.84 2.8%
Other 14,285.03 29.7% 474.07 29.6% 14,759.10 29.7%
Store Total 48,156.22 100.0% 1,600.58 100.0% 49,756.80 100.0%

ALL STORES
Grand Total 48,156.22 100.0% 1,600.58 100.0% 49,756.80 100.0%

Total Sales

Product Sales Report by Date by Occasion by Product
MARGIE'S FLOWERS

Sale Date 01/11/2008 - 02/11/2008
All Categories

Wire Out SalesInventory Sales

Occasion
Prod Code Name Description Sales Amt. %

MARGIE'S FLOWERS

Sympathy

A-V VASE ARR.

VASE ARR....from our web 
site......Elegant Tribute�
Customer would like white lilles 110.00 2.8%

BP-GEN BLOOMING PLANT- BLOOMING PLANT- 55.00 1.4%
C33-2960 The FTD White Assortment Basket 49.99 1.3%
C6-3067 The FTD Festive Wishes Bouquet 24.99 0.6%
FB FRUIT BASKET FRUIT BASKET 144.98 3.7%
S21-3156 The FTD Quiet Tribute Standing Spray 136.49 3.5%
WIRE Wire 60.01 1.5%

Occasion Total: 581.46 15.0%

Total Sales

Product Sales Report by Date by Occasion by Product
MARGIE'S FLOWERS

Sale Date 01/11/2008 - 01/14/2008
All Categories
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Generating Product Sales Reports
TASK To generate the Product Sales Report:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click Mercury Forms.
3 Double-click on the Product Sales Report icon to open the template.
4 If a window opens asking whether you wish to enable or disable macros, click Enable Macros.
5 Complete the options on the Product Sales Report window.
6 Click Finish. The report generates and opens in Excel.
7 To print your report from Excel, on the File menu, click Print.
8 If you want to save the report from Excel, on the File menu, click Save.

Product Sales Report Window
The Product Sales Report window allows you to configure settings for the Product Sales report. 
When you have finished configuring settings, click Finish to generate the report. It will open in 
Microsoft Excel.

Figure 19-43: Product Sales Report Window
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The Product Sales Report window contains the following settings.

Reciprocity Report
The Reciprocity Report provides you with an analysis of your reciprocity statistics by wire service. It 
prints the total number of orders and the dollar amount of orders that you have sent and received 
for each shop code for the month in which the order messages were sent. 

Figure 19-44: Reciprocity Report

Generating a Reciprocity Report
TASK To generate a Reciprocity Report:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click Mercury Forms.

Table 19-17: Product Sales Report Window Settings

Setting Description

Select Store From this list, select the store for which you want to generate the report. If you 
have multiple stores, you can select All Stores.

Product Report Select whether you want to generate a Product List report, a Sales by Product 
Code report, or Sales by Date, Occasion, and Product report.

Report Type Select whether you want to generate a detail report or a summary report.

Product Categories Select whether you to include all product categories in the report or select 
product categories from the list to include.

Sale Type Select whether you want to include inventory, wire out, or both sale types in your 
report.

Start Date Enter the start date for this report.

End Date Enter the end date for this report.

Date Type If you selected Sales by Product Code or Sales by Date, Occasion and Product, 
you need to specify the date types you want to include in the report. You can 
select one of the following: 

» Delivery Date—when this is selected, orders completed with a delivery 
date within the date range selected for the report will be included.

» Sale Date—when this is selected, orders completed within the date range 
selected for the report will be included. 
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3 Double-click on the Reciprocity Report icon to open the template.
4 If a window opens asking whether you want to enable or disable macros, click Enable Macros.
5 In the Wire Type area, select the wire service for the florists that you want to print reciprocity 

statistics.
6 In the Date field, click the arrow and select the date through which you want to print 

reciprocity statistics.
7 Click Finish. The report opens in Microsoft Excel.
8 To print your report from Excel, on the File menu, click Print.
9 If you want to save the report from Excel, on the File menu, click Save.

Reciprocity Report Window
The Reciprocity Report window allows you to configure settings for your Reciprocity report. When 
you have finished configuring settings, click Finish to generate the report. It will open in Microsoft 
Excel.

Figure 19-45: Reciprocity Report Window

The Reciprocity Report window contains the following settings.

Report of Orders Filled
The Report of Orders Filled lists all incoming orders that you filled and entered in your system over 
a chosen delivery date or date range. The report also provides the grand total number of orders 
filled and the dollar amount associated with the orders.

Table 19-18: Reciprocity Report Window Settings

Setting Description

Wire Type Select the wire service for which you want to generate the reciprocity statistics.

Month and Year Select the month and year for this report.
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Figure 19-46: Report of Orders Filled

Generating the Report of Orders Filled
TASK To generate the Report of Orders Filled:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click Mercury Forms.
3 Double-click on the Report Orders Filled icon to open the template.
4 If a window opens asking whether you wish to enable or disable macros, click Enable Macros.
5 In the Selection Type section, select whether you want to display orders filled by Shop Code or 

Wire Service.
6 If you selected Shop Code in the Selection Type section, click the arrow in the Shop Code field 

and select the shop for which you want to print orders filled. If you want to print orders filled for 
all shop codes, select All Shop Codes.

7 If you selected Wire Service in the Selection Type section, click the arrow in the Wire field and 
select the wire service for which you want to print orders filled. If you want to print orders filled 
for all wire services, select All Wire Services.

8 In the Delivery Date Range section, select the start and end dates for the delivery dates.
9 Click Finish. The report generates and opens in Excel.
10 To print your report from Excel, on the File menu, click Print.
11 If you want to save the report from Excel, on the File menu, click Save.

Report of Orders Filled Window
The Report of Orders Filled window allows you to configure settings for the Report of Orders Filled.
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Figure 19-47: Report of Orders Filled Window

The Report of Orders Filled window contains the following settings.

Sales by Referral Code Report
The Sales By Referral Code report lists total sales by referral code for a given sales date or date 
range. Referral codes are entered in Order Entry or Point of Sale in the payment screen at the time 
of sale. If a referral code is not entered at the time of sale, the referral code from the Customer 
Detail Information window is used (the customer detail that is accessed through a customer 
search). All Order Entry and Point of Sale transactions are included on the report. 

» The Summary Report lists each referral code and the total dollar amount of sales generated 
from each referral code. It then lists a grand total for all referral codes.

» The Detail Report lists each customer with the given referral code, and the dollar amount that 
the customer has spent for the given date range.

Table 19-19: Report of Orders Filled Window Settings

Setting Description

Selection Type Select to report on orders by shop code or wire service.

Shop Code If you selected to report on orders by shop code, select the code for the orders to 
include in the report or select to include all codes.

Wire If you selected to report on orders by wire service, select the wire service for the 
orders to include in the report or select to include all wire service types.

Delivery Date Range Select the delivery start and end dates to be included in the report.
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Figure 19-48: Sales By Referral Code Report - Detail
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Figure 19-49: Sales By Referral Code Report - Summary

Generating the Sales by Referral Code Report
TASK To generate the Sales by Referral Code report:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click the Mercury Forms icon on your desktop.
3 Double-click on the Sales by Referral Code Report icon to open the template.
4 If a window opens asking whether you wish to enable macros, click Enable Macros.
5 If you receive the message “This application is about to initialize ActiveX controls...” click OK.
6 In the Select Store field, click the arrow and select the store’s data that you want to use for the 

report. 
7 In the Start Date field of the Date Range section, click the arrow and choose the date on which 

you wish to start analyzing sales information. In the End Date field, click the arrow and choose 
the date on which you wish to end analyzing sales summary information.

8 In the Report Type area, select if you want to print the Detail Report or Summary Report.
9 If you want to print customers with particular marketing types, click Marketing Criteria 

Selection so that a check mark appears (otherwise leave this option unchecked). This allows 
you to filter customer information so that, for example, you can print only Business accounts in 
the report. (If this area is blank, it means that you have no marketing categories set up. See 
Marketing Screen on page 24–21 for information on setting up these categories.)
To select marketing categories to print, first click on a category so that a drop-down arrow 
displays. Click this arrow to display a drop-down list of marketing types. Then check which 
types you want to print.
To print only customers with no marketing information specified in the Customer Detail 
Information window, first check the Marketing Criteria Selection option so that a check 
mark appears, then check Customers with No Marketing Criteria.

10 Select how you want to sort the report: by Sort Name (customer name), Amount, or Last 
Purchase Date.

11 Click Finish.
12 To print your report from Excel, on the File menu, click Print.
13 If you want to save the report from Excel, on the File menu, click Save.
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Sales by Referral Code Report Window
The Sales by Referral Code Report window allows you to configure settings for the Sale by Referral 
Code report. When you have finished configuring settings, click Finish to generate the report. It will 
open in Microsoft Excel.

Figure 19-50: Sales by Referral Code Report Window

The Sales by Referral Code Report window contains the following settings.

Table 19-20: Sales by Referral Code Report Window Settings

Setting Description

Select Store From this list, select the store for the report. If you have multiple stores, you can 
select All Stores.

Date Range Select the sales start and end dates for the report.

Report Types Select whether you are generating the Detail or Summary report.

Marketing Criteria 
Selection

If you select this option, you can filter the report so it includes customers with 
specific marketing criteria or no marketing criteria. If you select Customers with 
Marketing Criteria, you can select the marketing categories to include.

Sort Option You can select to sort the report by Sort Name, the Last Purchase Date, or by 
Amount.



Chapter 19
Business Reports

19–50

Sales Summary Report
The Sales Summary report summarizes total completed sales for your store for a given sale or 
delivery date or date range. Information in the Sales Summary is reported on an accrual basis. 
Because the Sales Summary reports information by statement categories, such as merchant 
amount, delivery charge, or discount amounts, information in the Sales Summary is comparable to 
information in the Sales Tax report, if the Sales Tax report is run on an accrual basis for the same 
reporting period and date type (delivery date or sale date).

The Sales Summary report has several parts.

» Order Entry/Manual - shows total sales, gift certificates purchased and redeemed, outgoing 
and incoming sales according to wire service, and payments received for Order Entry and 
manual tickets.

» POS - shows total sales, gift certificates purchased and redeemed, outgoing and incoming sales 
according to wire service, and payments received for Point of Sale. In order for this section of 
the report to appear, you must be configured to use POS. 

» Total Sales - shows combined totals for Order Entry/manual tickets and Point of Sale. 

» Other - shows finance charges and manual entry for POS systems that are not part of FTD 
Mercury. 

» Store Transfers - lists store transfers. In order for data to appear in this section of the report, 
store transfer journal entries must have been created. For more information, see Store Transfers 
Screen on page 24–22.

Order Entry/Manual, POS, and Total Sales
These sections of the report show the number of sales, merchant product charge, other chargers, 
coupons, discounts, and tax for total sales as well as for subcategories such as gift certificates, wire 
sales, and payments received. 
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Figure 19-51: Sales Summary Report Order Entry/ManualSection
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Figure 19-52: Sales Summary Report POS Section 

Figure 19-53: Sales Summary Report Total Sales Section
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The Sales Summary report Order Entry/Manual, POS, and Total Sales sections contain the following 
fields.

IMPORTANT When gift cards and gift certificates are purchased, the method of payment used is included in the Sales 
Summary report, and the number of these items purchased is included as well. However, because gift 
cards and gift certificates are prepayments for future sales, their values are only included in local or wire 
out sales totals when they are redeemed.

Table 19-21: Sales Summary Report Order Entry/Manual, POS, and Total Sales Sections Field Descriptions

Column Description

Units Number of sales of a given type.

Merch Amount Value of the statement category Product Amount for the sales of a given 
type.

Delivery Charges Value of the statement category Delivery Charge for the sales of a given 
type.

Relay Charges Value of the statement category Relay Charge for the sales of a given type.

Service Charges Value of the statement category Service Charge for the sales of a given type.

Coupons Value of the statement category Coupon for the sales of a given type.

Discount Amount Value of the statement category Discounts for the sales of a given type.

Total Without Tax Sum of the sales’ merchant amount, delivery charge, relay charge, and 
service charges less discount and coupon amounts.

Sales Tax Value of sales tax for the sales of a given type.

Total Sum of Total without Tax and Sales Tax for the sales of a given type.

Percentage Percent of total sales that the row represents.

Total Sales Summary Summarizes total sales by payment method.

NOTE: When debit cards are entered in Order Entry, the sales is 
reported under Preauthorized Credit Card Sales. When debit 
cards are used in POS, the sale is reported under Debit Cards.

Gift Certificate/Card 
Summary

Summary of sales in which gift cards and gift certificates were purchased 
and redeemed.

Total Outgoing Sales Summary of outgoing sales.

Total Pending Outgoing 
Sales

Summary of outgoing sales that are waiting to be transmitted.

Total Local Sales Summary of local sales.

Incoming Sales Summary Summarizes incoming wire sales by wire service, including phoned in orders.

Outgoing Wire Summary Summarizes outgoing wire sales by wire service. Includes statement 
category types of product and delivery.

Payments Received For amounts received for house account payments. 
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Other Section
The Other section of the Sales Summary report shows the total finance charges if statements were 
run. It also shows the number of sales, merchant product charge, other chargers, coupons, 
discounts, and tax for manual Point of Sale transactions.

Figure 19-54: Sales Summary Report Other Section

Store Transfer Section
The Store Transfer section of the Sales Summary report shows sales transferred and sales received 
from transferred orders.

Figure 19-55: Sales Summary Report Store Transfer Section

The Sales Summary report Store Transfer section contains the following fields.

Table 19-22: Sales Summary Report Store Transfer Field Descriptions

Column Description

Units Number of sales transferred to or from other stores.

Merch Amount Value of the statement category Product Amount for the sales transferred to 
or from other stores. For Income Retained, Merchant Amount is calculated as 
the value of the statement category for Product Amount less the filling 
percentage.

Delivery Charges Value of the statement category Delivery Charge for the sales transferred to 
or from other stores. For Income Retained, Delivery Charge is calculated as 
the value of the statement category for Delivery Charge less the filling 
percentage.

Less Discounts Value of discounts applied to Merchant Amount or Delivery Charges on sales 
transferred to or from other stores.

Total Value of transfers to and from other stores calculated as Merchant Amount 
plus Delivery Charges less Discounts.

Value of Sales Transferred 
to Other Stores

Value of merchant amount, delivery charge, and discount that the store 
transfers to other stores.
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Generating the Sales Summary Report
TASK To generate the Sales Summary report:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click Mercury Forms.
3 Double-click on the Sales Summary Report icon to open the template.
4 If a window opens asking whether you wish to enable macros, click Enable Macros.
5 When the Sales Summary Report window opens:

a. In the Select Store field, click the arrow and select the store’s data that you want to use for 
the report.

b. In the Start Date field of the Sale Date Range area, click the arrow and choose the date on 
which you wish to start analyzing sales summary information.

c. In the End Date field, click the arrow and choose the date on which you wish to end 
analyzing sales summary information.

d. Select if you want to print the report according to Delivery Date or Sale Date.
e. Click Finish. The report generates and opens in Excel.

6 To print your report from Excel, on the File menu, click Print.
7 If you want to save the report from Excel, on the File menu, click Save.

Sales Summary Report Window
The Sales Summary Report window allows you to configure settings for the Sales Summary 
Report. When you have finished configuring settings, click Finish to generate the report and open 
it in Microsoft Excel.

Income Retained Value of merchant amount, delivery charge, and discount that the store 
retains. Calculated by reducing the values of sales transferred by a filling 
percentage. 

Total Revenue Transferred Value of sales transferred less income retained.

Value of Sales Received 
from Other Stores

Value of merchant amount, delivery charge, and discount that the store 
receives from other stores.

Commissions Paid Value of merchant amount, delivery charge, and discount that the store 
receives for sales transferred to the store. Calculated by multiplying the 
values of sales transferred by a selling commission. 

Total Revenue Received Value of merchant amount, delivery charge, and discounts received from 
sales transferred to the store less the commissions paid on sales transferred 
to other stores.

Table 19-22: Sales Summary Report Store Transfer Field Descriptions (cont.)

Column Description
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Figure 19-56: Sales Summary Report Window

The Sales Summary Report window contains the following settings.

Sales Tax Report
The Sales Tax report is used to provide information to assist in completing the monthly sales tax 
report that you are required to file with your state or province. Although this report is beneficial in 
many states, each state is required to file different reports.

The Sales Tax report is sorted by Taxable Sales and Non Taxable Sales, and the sales tax paid for 
each tax code. Tax figures can be based on either delivery or sale dates. The sales tax is calculated 
according to the rate that you define in Mercury Administration.

You can select whether you want to print by Accrual or Cash Basis. Accrual includes dollar amounts 
for house account charges that have not yet been paid. Cash Basis only includes actual cash that 
you have received.

Table 19-23: Sales Summary Report Window Settings

Setting Description

Select Store From this list, select the store you want to use for the report. If you are set up as a 
multi-store shop, you can also select All Stores.

Sale Date Range Select the start and end dates to use to analyze sales summary information.

Date Type Select whether you want to print the report according to Delivery Date or Sale 
Date.
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Figure 19-57: U.S. Sales Tax Report

If your system is set up as Canadian, the Sales Tax report will contain a section called Additional Tax 
Items. In it, taxes on commissions earned and taxes on orders received will be broken out based on 
information entered in the Canadian Sales Tax window. Additionally, there will be a section for 
Input Tax Credits, based on Point of Sale paid out transactions, taxes paid to the filling florists, taxes 
paid on commissions, taxes paid on fees and services, and taxes paid on Accounts Payable invoices.
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Figure 19-58: Canadian Sales Tax Report

Generating the U.S. Sales Tax Report
TASK To generate the Sales Tax report if you are a U.S. shop:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click Mercury Forms.
3 Double-click on the Sales Tax Report icon to open the template.
4 If a window opens asking whether you wish you enable or disable macros, click Enable Macros.
5 When the Sales Tax Report window opens:

a. From the Select Store list, select the store for which you are generating the report. You can 
also select All Stores if you are configured as a multiple store shop.
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b. In the Month and Year area, select the starting and ending dates for the report. Data 
included in the report will start on the date you specify in the Start field and will include 
data up to and including data for the date you select in the End field.

c. In the Type area, select whether you want the data to be included based on Accrual or 
Cash Basis.

d. If you selected Accrual as the Type, in the Date Types area, select whether you want the 
dates to be based on delivery date or sales date.

e. Select Delivery Date or Sale Date to determine the date on which tax figures will be based.
f. Click Finish. The report generates and opens in Excel.

6 To print your report from Excel, on the File menu, click Print.
7 If you want to save the report from Excel, on the File menu, click Save.

Generating the Canadian Sales Tax Report
TASK To generate the Sales Tax report if you are a Canadian shop:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click Mercury Forms.
3 Double-click on the Sales Tax Report icon to open the template.
4 If a window opens asking whether you wish you enable or disable macros, click Enable Macros.
5 When the Sales Tax Report window opens:

a. From the Select Store list, select the store for which you are generating the report. You can 
also select All Stores if you are configured as a multiple store shop.

b. In the Month and Year area, select the starting and ending dates for the report. Data 
included in the report will start on the date you specify in the Start field and will include 
data up to and including data for the date you select in the End field.

c. In the Type area, select whether you want the data to be included based on Accrual or 
Cash Basis.

d. If you selected Accrual as the Type, in the Date Types area, select whether you want the 
dates to be based on delivery date or sales date.

e. Select Delivery Date or Sale Date to determine the date on which tax figures will be based.
f. Click Next.

6 When the Canadian Sales Tax window opens, enter additional tax entries and/or input tax 
credits for wire service statements or accounts payable. Additional taxes entered in this window 
appear in the first column of the Sales Tax report, under the label defined as Federal Tax in 
Mercury Administration.

7 Click Finish. The report generates and opens in Excel.
8 To print your report from Excel, on the File menu, click Print.
9 If you want to save the report from Excel, on the File menu, click Save.

Sales Tax Report Window
Regardless of whether FTD Mercury is configured as a Canadian system or as a U.S. system, this 
window opens when you open the Sales Tax Report template. The settings you select determine 
the content of the Sales Tax report. For U.S. shops, when you click Finish, the report generates. For 
Canadian shops, clicking the Next button opens the Canadian Sales Tax window.
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Figure 19-59: Sales Tax Report Window

The Sales Tax Report window contains the following settings.

Canadian Sales Tax Window
When you are generating a Sales Tax report, and you are a Canadian shop, when you click Next on 
the Sales Tax Report window, the Canadian Sales Tax window opens. This window enables you to 
enter additional tax entries and/or input tax credits for wire service statements or accounts 
payable. Additional taxes entered in this window appear in the first column of the Sales Tax report, 
under the label defined as Federal Tax in Mercury Administration.

Table 19-24: Sales Tax Report Settings

Setting Description

Select Store Select the store for which you want to generate the report. If you have multiple 
stores, you can select All Stores to generate a Sales Tax Report that includes data 
from all of your stores.

Start Select the starting date for the report.

End Select the ending date for the report.

Type Select whether you want your report to include data based on one of the 
following types:

» Accrual—includes dollar amounts for house account charges that have not 
yet been paid. If you select this option, you need to specify the Date Types 
you want to include.

» Cash Basis—only includes actual cash you have received.

Date Types If you selected Accrual as the Type, you need to specify the date types you want 
to include in the report. You can select one of the following: 

» Delivery Date—when this is selected, orders completed with a delivery 
date within the months selected for the report will be included.

» Sale Date—when this is selected, orders completed with an entry date 
within the months selected for the report will be included. 
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Tax amounts entered in this window are included in the totals generated on the Sales Tax report 
regardless of whether you selected Accrual or Cash Basis as the report type in the Sales Tax Report 
window.

Figure 19-60: Canadian Sales Tax Window

The Canadian Sales Tax window contains the following settings:

Table 19-25: Canadian Sales Tax Window Settings

Field Description

Store Displays the name of your store. You cannot change this setting from this 
window.

Tax Paid to Filling Florist 
Canadian Outgoing Orders

Enter the taxes paid to filling florists on outgoing orders within Canada. 
This value can be found on your FTD Clearinghouse Statement.

Tax on Commissions Earned 
Canadian Outgoing Orders

Enter the taxes on commissions earned on outgoing orders within 
Canada. This value can be found on your FTD Clearinghouse Statement.

Tax on Orders Received 
Canadian Incoming Orders

Enter the taxes on orders received for incoming orders within Canada. This 
value can be found on your FTD Clearinghouse Statement.

Tax Paid on Commissions 
Canadian Incoming Orders

Enter the taxes paid on commissions for incoming orders within Canada. 
This value can be found on your FTD Clearinghouse Statement.

Misc. GST/HST Taxes Paid on 
Fees or Services

Enter the miscellaneous GST or HST taxes paid on services and fees. This 
value can be found on your FTD Clearinghouse Statement.

GST/HST Tax Paid on 
Business Related AP Invoices

Enter the amount of GST or HST taxes paid on business-related accounts 
payable invoices. Usually, this value is calculated in stored in your 
accounting software. Consult your accountant for details on the value to 
enter.
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Standing Order Log Detail Report
The Standing Order Log Detail Report provides you with a list of every standing order template 
that has had orders generated from it during a selected delivery date range. Depending on the 
options selected in the FTD Mercury Standing Order Log window, this report may be sorted by 
customer, frequency, or store.

Figure 19-61: Standing Order Log Detail Report

The Standing Order Log Detail Report contains the following information:

Table 19-26: Standing Order Log Detail Report Columns

Column Description

Customer The name of the customer with whom the standing order template is 
associated.

Recipient The recipient of the orders generated by this standing order template.

Total The total order price for each order generated by the standing order 
template.

Recurrence Pattern The frequency at which the order recurs. This does not display any additional 
dates added to the standing order template, nor any dates removed.

Start Date The start date of the standing order template, and the date on which the first 
order was (or is to be) delivered.

End Date The date on which the standing order template will expire. This may be 
different than the Last Delivery Date.

Template ID The ID of the standing order template in the system.
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Generating a Standing Order Log Detail Report
TASK To generate a Standing Order Log Detail report:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click Mercury Forms.
3 Double-click on the Standing Order Log icon to open the template.
4 If a window opens asking whether you wish to enable or disable macros, click Enable Macros.
5 In the Standing Order Log window, select the store for which you want to generate the report. 

You can also select All Stores to generate a report for all stores (if you are a multi-store shop).
6 Select whether you want the report sorted by Customer, Frequency, or Store.
7 In the Report Type area, select Summary.
8 In the Date Range area, specify the start and end dates for the range. Orders created from 

standing order templates during this date range will be included in the report.
9 Click Finish.
10 To print your report from Excel, on the File menu, click Print.
11 If you want to save the report from Excel, on the File menu, click Save.

Standing Order Report Window
The Standing Order Report window allows you to customize the Standing Order Log Summary 
and Standing Order Log Detail reports. 

Creation Date The date this order was or will be generated from the standing order 
template.

Delivery Date The delivery date for this order.

Status/Order Number Either the order number for this order, or the status of the order if it either 
has not been created yet (Pending) or if it could not be created (Failed).

Store The store with which the standing order template is associated.

Table 19-26: Standing Order Log Detail Report Columns (cont.)

Column Description
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Figure 19-62: Standing Order Report Window

The Standing Order Report window contains the following settings.

Standing Order Log Summary Report
The Standing Order Log Summary report provides you with a list of all open standing orders for a 
store (or all stores if you are a multi-store shop), sorted by customer, frequency, or store.

Table 19-27: Standing Order Report Window Settings

Setting Description

Select Store Select the store for which you are generating the Standing Order Log Summary report. If 
you are multi-store, you can also select All Stores to generate a combined list.

Sort By Select whether you want to sort the report by customer, store, or frequency (recurrence 
pattern).

Report Type Select whether you want to generate a Detail report or a Summary report.

Date Range If you are creating a Detail report, specify a date range. The report will include all orders 
created from standing order templates in the range.
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Figure 19-63: Standing Order Log Summary Report

The Standing Order Log Summary report contains the following information:

Table 19-28: Standing Order Log Summary Report Columns

Column Description

Customer The name of the customer with whom the standing order template is 
associated.

Recipient The recipient of the orders generated by this standing order template.

Total The total order price for each order generated by the standing order 
template.

Recurrence Pattern The frequency at which the order recurs. This does not display any additional 
dates added to the standing order template, nor any dates removed.

Start Date The start date of the standing order template, and the date on which the first 
order was (or is to be) delivered.

End Date The date on which the standing order template will expire. This may be 
different than the Last Delivery Date.

Next Generation Date The date on which the next order is to be generated by this standing order 
template.

Previous Delivery Date The delivery date for the most recent order generated by this standing order 
template.

Next Delivery Date The date the next order generated by the standing order template is 
scheduled for delivery.

Last Delivery Date The final delivery date for orders generated by this template.

Store The store with which the standing order template is associated.
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Generating a Standing Order Log Summary Report
TASK To generate a Standing Order Log Summary report:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click Mercury Forms.
3 Double-click on the Standing Order Log icon to open the template.
4 If a window opens asking whether you wish to enable or disable macros, click Enable Macros.
5 In the Standing Order Log window, select the store for which you want to generate the report. 

You can also select All Stores to generate a report for all stores (if you are a multi-store shop).
6 Select whether you want the report sorted by Customer, Frequency, or Store.
7 In the Report Type area, select Summary.
8 Click Finish. The report generates and opens in Excel.
9 To print your report from Excel, on the File menu, click Print.
10 If you want to save the report from Excel, on the File menu, click Save.

Tax Exempt Customer Report
The Tax Exempt Customer report lists all tax exempt customers that have had sales within the 
specified date range. It lists the customer ID and name, phone number, tax exempt ID and the sales 
tax paid (if any), and the total dollar amount spent. A grand total of sales without tax is also 
displayed at the bottom of the report.

» The Detail Report lists each tax exempt customer, as well as all of the customer’s transactions 
within the specified date range. The report also lists the date of each transaction, and the 
transaction type and dollar amount.

» The Summary Report lists each tax exempt customer that had transactions within the specified 
date range, and the total dollar amount spent.

Figure 19-64: Tax Exempt Customer Report - Detail
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Figure 19-65: Tax Exempt Customer Report - Summary

Generating the Tax Exempt Customer Report
TASK To generate the Tax Exempt Customer report:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click Mercury Forms.
3 Double-click on the Tax Exempt Customer Report icon to open the template.
4 If a window opens asking whether you wish you enable or disable macros, click Enable Macros.
5 When the Tax Exempt Customer Report window opens:

a. In the Select Store field, click the arrow and select the store’s data that you want to use for 
the report. 

b. In the Start Date field of the Date Range section, click the arrow and select the sale date to 
begin printing tax information.

c. In the End Date field, click the arrow and select the sale date to end printing tax 
information.

d. Select the report type, Detail or Summary.
e. If you want to include wire service accounts in the report, select Include Wire Service 

Accounts so that a check mark appears.
f. Click Finish. The report generates and opens in Excel.

6 To print your report from Excel, on the File menu, click Print.
7 If you want to save the report from Excel, on the File menu, click Save.

Tax Exempt Report Window
The Tax Exempt Report window allows you to configure settings for the Tax Exempt report. When 
you have finished configuring settings, click Finish to generate the report. It will open in Microsoft 
Excel.
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Figure 19-66: Tax Exempt Customer Report Window

The Tax Exempt Report window contains the following settings.

Ticket Report
The Ticket report provides you with an analysis of each ticket type, the products ordered on each 
ticket, and the cost and quantity of products ordered per ticket, for the given sales date or date 
range. You can select which ticket types you want to include: Order Entry, Manual Ticket, and/or 
Point of Sale tickets.

Table 19-29: Tax Exempt Report Window Settings

Setting Description

Select Store Select the store for which you want to generate the report. If you have multiple 
stores, you can select All Stores to generate a report that includes data from all of 
your stores.

Date Range Select the sales start and end dates for the report.

Report Type Select whether you want to generate a summary or detail report.

Include Wire Service 
Accounts

Check the box to include wire service accounts in the report.
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Figure 19-67: Manual Ticket Report

Generating a Ticket Report
TASK To generate a Ticket report:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click Mercury Forms.
3 Double-click on the Ticket Report icon to open the template.
4 If a window opens asking whether you wish to enable or disable macros, click Enable Macros.
5 In the Select Store field, click the arrow and select the store’s data that you want to use for the 

report.
6 In the Sale Type section, select the types of tickets that you want to include in your report: 

Order Entry, POS, and/or Manual Ticket.
7 In the Sort Option section, decide if you want to sort the report by Customer, Date, or Type.
8 In the Date Range section, select a sales start and end date for the data that you want to 

include in the report.
9 Click Finish. The report generates and opens in Excel.
10 To print your report from Excel, on the File menu, click Print.
11 If you want to save the report from Excel, on the File menu, click Save.

Ticket Report Window
The Ticket Report window allows you to configure settings for the Ticket report. When you have 
finished configuring settings, click Finish to generate the report. It will open in Microsoft Excel.
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Figure 19-68: Ticket Report Window

The Ticket Report window contains the following settings.

Wire Reconciliation Report
The Wire Reconciliation report lists disputed, reconciled and/or not-reconciled orders for a 
specified delivery date or date range. You may choose to pull your data from the Combined Report 
or from the Message Log within FTD Mercury. 

NOTE The following message types are excluded from the report: Error, EFOS Rejected, Pending, Rejected, 
Cancel, and Confirmation.

Table 19-30: Ticket Report Window Settings

Setting Description

Select Store Select the store for which you want to generate the report. If you have multiple 
stores, you can select All Stores to generate a report that includes data from all of 
your stores.

Sale Type Select the type of tickets to include in the report. You can select Order Entry, 
Manual, and POS.

Sort Option Select to sort the report by customer, date, or type of sale.

Date Range Select the sales start and end dates for the report.
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Figure 19-69: Wire Reconciliation Report

Generating the Wire Reconciliation Report
TASK To generate the Wire Reconciliation report:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click Mercury Forms.
3 Double-click on the Wire Reconciliation icon to open the template.
4 If a window opens asking whether you wish to enable or disable macros, click Enable Macros.
5 When the Wire Reconciliation window opens:

a. In the Wire Service field, click the arrow to display a list of wire services. Highlight and 
select the wire service for which you want to generate this report.

b. In the Reconciliation Status section, click in any combination of the Disputed, Reconciled, 
and Not-Reconciled check boxes so check marks appear to indicate which statuses you 
wish to include in this report.

c. In the From field of the Delivery Date Range area, click the arrow to display a calendar. Use 
your mouse to click on the date from which you want to list orders.

d. In the To field, click the arrow to display a calendar. Use your mouse to click on the date that 
your system will end listing orders.

e. In the Data Source section, choose to pull your reconciliation data either from the 
Statement Reconciliation Items (data from the Combined Report) or your System Wire/
Phone Orders (data from your Message Log).

f. In the Sort Option section, select whether you want to sort the report by Mercury ID, Shop 
Code, or Reconciliation Status.

Type Shop Code Mercury  # Recipient Delivery Date Dollar Amount Reconciled Status

FTD OUT 90-5893AF O6703B-8746 Frank Cameron 7/20/2005 49.99 Reconciled
FTD OUT 90-5893AF O6644F-9797 Jenny Markus 7/20/2005 62.98 Disputed
FTD OUT 90-5893AF O7852X-9798 Jamie Jones 7/20/2005 73.98 Reconciled
FTD OUT 90-5893AF O3892R-9230 Carrie Smith 7/20/2005 50.00 Reconciled
FTD IN 90-0154AA P8392N-3892 Frances Gable 7/20/2005 129.99 Reconciled
FTD IN 90-8903AA P8478K-3891 Mr. Dorian Moros 7/20/2005 59.99 Reconciled
FTD IN 90-7834AB P4901L-9039 Francesca Milo 7/20/2005 49.99 Reconciled
FTD IN 90-5691AA Q0927J-0667 Candida Rodriquez 7/20/2005 99.99 Reconciled
FTD IN 90-8201AA P4890V-9875 Penny Smith 7/20/2005 89.99 Reconciled

Totals:
8 Reconciled: 603.92
1 Disputed: 62.98
0 Not-Reconciled: 0.00

Number of Total Sender Sender Wire Service Wire Service
Orders Amount Rate Commission Rate Commission

Total Reconciled Incoming
under 30.00 0 0.00 10.00% 0.00 7.00% 0.00
30.01 - 99999.99 5 429.95 20.00% 85.99 7.00% 30.10

Total 5 429.95 85.99 30.10

Total Reconciled Outgoing
under 30.00 0 0.00 10.00% 0.00
30.01 - 99999.99 3 173.97 20.00% 34.79

Total 3 173.97 34.79

313.86
139.18
174.68

Amount Received on Incoming
Amount Paid on Outgoing

Amount Due from FTD
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g. Click Finish. The report generates and opens in Excel.
6 To print your report from Excel, on the File menu, click Print.
7 If you want to save the report from Excel, on the File menu, click Save.

Wire Reconciliation Window
The Wire Reconciliation window allows you to configure settings for the Wire Reconciliation 
Report. When you have finished configuring your settings, click Finish to generate the report and 
open it in Microsoft Excel.

Figure 19-70: Wire Reconciliation Window

The Wire Reconciliation window contains the following settings.

Table 19-31: Wire Reconciliation Window Settings

Setting Description

Wire Service Select the wire service for which you are generating this report.

Reconciliation Status Select the status(es) you want to include in the report. You can select Disputed, 
Reconciled, and/or Not-Reconciled.

Delivery Date Range Select the start and end delivery dates for the report.

Data Source Select whether you want the data source to be statement reconciliation items or 
system wire/phone orders.

Sort Option Select whether you want the report sorted by Mercury ID, shop code, or 
reconciliations status.
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Wire Service Incoming/Outgoing Report
The Wire Service Incoming/Outgoing report prints all incoming and outgoing orders by wire 
service for the given date range. If you have multiple stores, you can select to print a specific store, 
or you can print all locations in one report. Printing all locations will print a grand totals section at 
the bottom of the report.

» The Detail Report lists the shop code, recipient name, delivery date, and amount for each 
incoming and outgoing order. Listed are incoming totals, outgoing totals, a grand incoming 
and outgoing total, and a grand total for all orders.

» The Summary Report lists the total dollar amount for incoming and outgoing orders. A grand 
total for incoming, outgoing, and all orders are listed.

Figure 19-71: Wire Service Incoming/Outgoing Report - Detail



Chapter 19
Business Reports

19–74

Figure 19-72: Wire Service Incoming/Outgoing Report - Summary

Generating the Wire Service Incoming/Outgoing Report
TASK To generate the Wire Service Incoming/Outgoing report:

1 On the FTD Mercury Main Menu, click Business Reports.
2 Double-click Mercury Forms.
3 Double-click on the Wire Service Incoming Outgoing icon to open the template.
4 If a window opens asking if you wish to enable macros, click Enable Macros.
5 If you have multiple stores, select the store in the Select Store field.
6 In the Wire Type section, select the wire service(s) that you want to include in the report. The 

DOV wire service is for incoming Teleflora orders, if you have the Wire Service Interface.
7 In the Date Range section, select the start and end sale dates for the data that you want to 

include in the report.
8 In the Report Type section, select if you want to print the Detail Report or the Summary 

Report.
9 Select how you want to sort the report: by Date, Name (recipient name), or Amount.
10 Click Finish. The report generates and opens in Excel.
11 To print your report from Excel, on the File menu, click Print.
12 If you want to save the report from Excel, on the File menu, click Save.

Wire Service Incoming/Outgoing Window
The Wire Service Incoming/Outgoing window allows you to configure settings for the Wire Service 
Incoming/Outgoing report. When you have finished configuring settings, click Finish to generate 
the report. It will open in Microsoft Excel.
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Figure 19-73: Wire Service Incoming/Outgoing Window

The Wire Service Incoming/Outgoing window contains the following settings.

Table 19-32: Wire Service Incoming/Outgoing Window Settings

Setting Description

Select Store Select the store for which you are generating this report. If you are configured as 
a multi-store shop, you can also select All Stores.

Wire Type Select the wire type(s) you want to include in this report. You can select from 
FTD, VNS, TEL, or DOV.

Start Date Enter the starting date for the report.

End Date Enter the ending date for the report.

Report Type Select whether you want to generate a Detail or Summary report.

Sort Option You can select whether you want o sort the report by Message Date, Amount, or 
Name.



Chapter 19
Business Reports

19–76




